Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#4446 closed defect (fixed)

Collaboration not working due to use of private _shared_activity

Reported by: godiard Owned by:
Priority: High Milestone:
Component: untriaged Version: Unspecified
Severity: Major Keywords: regression Australia
Cc: sridhar Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The following activities have broken collaboration:

calculate: (shareable_activity.py)

distance: (activity.py)

maze: (olpcgames/mesh.py)

memorize: (activity.py)

physics: (mesh.py)

pippy: groupthink/sugar_tools.py and pippy/mainline/pippy_app.py)

portfolio: (PortfolioActivity.py)

record: (collab.py)

speak: (toolkit/activity.py)

stopwatch: (activity.py)

tamtam: (JamMain.py)

turtleart: (tacollaboration.py and gnome_plugins/collaboration_plugin.py)

write: (AbiWordActivity.py) #4436

This ticket is to coordinate the fix in all the activities. If needed, fill new tickets.

Change History (7)

comment:1 Changed 6 years ago by walter

You missed a few others of my activities, but in any case, portfolio and turtle art are fixed in git (a new release for each is coming as soon as I work out some other issues).

comment:2 Changed 6 years ago by sridhar

  • Cc sridhar added
  • Keywords Australia added

comment:3 Changed 6 years ago by erikos

comment:4 Changed 6 years ago by godiard

After more testing, I found the problem is only with activities ported to gtk3,
then the list of activities we need modify is reduced:

distance: (activity.py)

pippy: groupthink/sugar_tools.py and pippy/mainline/pippy_app.py)

portfolio: (PortfolioActivity.py) (already solved in git)

stopwatch: (activity.py)

write: (AbiWordActivity.py)

comment:5 Changed 6 years ago by godiard

Finally, I found the issue with distance, pippy and stopwatch. The maintainers are not using the master branch to do the releases, but the branch gtk3. This problem was fixed in that branch.

Anyway we need coordinate with the maintainers because by example, pootle continue pushing to master.

Then, the only pending activities are portfolio (solved in git) and write.

This issue is solved in write already, but there are some other issue and collaboration is not reliable enough yet (SL #4436)

comment:6 Changed 6 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Close, as the fixes are already commited. Write is included in os36, Portfolio is in git.

comment:7 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.