Opened 8 years ago

Closed 8 years ago

#4436 closed defect (fixed)

Collaboration not working on "Write" (version-86) across any platform

Reported by: ajay_garg Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: 0.98.x
Severity: Major Keywords: regression Australia
Cc: ajay_garg, sridhar, greenfeld, dsd, erikos Distribution/OS: OLPC
Bug Status: Unconfirmed

Change History (9)

comment:1 Changed 8 years ago by ajay_garg

  • Cc ajay_garg added
  • Description modified (diff)

comment:3 Changed 8 years ago by sridhar

  • Cc sridhar added
  • Keywords regression Australia added

comment:4 Changed 8 years ago by godiard

  • Distribution/OS changed from Fedora to OLPC
  • Severity changed from Unspecified to Major
  • Version changed from Git as of bugdate to 0.98.x

comment:5 Changed 8 years ago by godiard

comment:6 Changed 8 years ago by godiard

  • Cc Cerlyn dsd erikos added

http://dev.laptop.org/~gonzalo/activities/Write-87.1.xo have a improved version than show the activity is establishing the connection, and disable the abi widget until communication is established.

This activity can't collaborate 100% times. I see many problems, but I don't know if is in the activity or in lower part of the stack.

  • At times, the collaboration is ok.
  • At times, both instances start but show different documents, and never sync.
  • At times, the changes in the joiner ar lost, but the changes in the offering xo are propagated.

Other issue related with collaboration saw are:

  • On time, the activity was closed in both xos, but a Write icon continued in the neighborhood view until restarted the xo.
  • Another time, the python process didn't ended (see #4454). I needed kill the process before be able to establish another successful collaboration.

I have tried with one xo-4 B1 and one xo-4 C1, first with os32 and later with os34. Also tried with "iw dev eth0 set power_save off" in the C1 unit. I think is a little better but still there are a lot of fails.

Then, while the _shared_activity issue is solved, there are something more not working.

comment:7 Changed 8 years ago by greenfeld

  • Cc greenfeld added; Cerlyn removed

comment:8 Changed 8 years ago by godiard

Uploaded Write 88 to aslo. The only change is hide by default the "connecting" message.

I don't know why this is visible in xo-1.5 but not in xo-4

Testing collaboration between two xo-1.5, collaboration is working in a much reliable way than in xo-4. I don't know if the problems are related with my environment, confirmation is welcomed.

comment:9 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Solved on Write 90

Note: See TracTickets for help on using tickets.