Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4037 closed defect (fixed)

Write-80 fail to start open a file

Reported by: cjl Owned by: godiard
Priority: Unspecified by Maintainer Milestone:
Component: Write Version: Unspecified
Severity: Unspecified Keywords: olpc-test-passed
Cc: dsd Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Write-80 fails to start - XO-4b1 OS6

Traceback (most recent call last):

File "/usr/bin/sugar-activity", line 160, in <module>

main()

File "/usr/bin/sugar-activity", line 118, in main

module = import(module_name)

File "/home/olpc/Activities/Write.activity/AbiWordActivity.py", line

31, in <module>

from abiword import Canvas

ImportError: No module named abiword Exited with status 1, pid 1148 data (None, <open file '<fdopen>', mode 'w' at 0x135e5a0>, 'ae9c164e3f6ce3362be57f99452c8305e323d351')

Downgraded to Write-79, same error

Downgraded to OS5, Write-79 works fine, Write-80 (perhaps not unexpectedly) fails to start

Attachments (8)

org.laptop.AbiWordActivity-1.log (1.9 KB) - added by cjl 10 years ago.
org.laptop.AbiWordActivity-2.log (1.8 KB) - added by cjl 10 years ago.
org.laptop.AbiWordActivity-3.log (1.8 KB) - added by cjl 10 years ago.
success.AbiWordActivity-1.log (2.8 KB) - added by cjl 10 years ago.
success.AbiWordActivity-6.log (2.8 KB) - added by cjl 10 years ago.
abi_bt.txt (3.3 KB) - added by godiard 10 years ago.
bt running abiword in a terminal
abiword.spec (30.9 KB) - added by godiard 10 years ago.
avoid-maliit-crash.patch (545 bytes) - added by godiard 10 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 Changed 10 years ago by dsd

  • Cc dsd added

Line 31 of AbiWordActivity.py in Write 80 is not "from abiword import Canvas"

This suggests that you might not really have been running Write-80. It rather looks like Write-79. Can you double check?

comment:2 Changed 10 years ago by cjl

I did go to Terminal and look at activity.info in /Activities/Wirte.activity/activity to make sure which version I was on.

I'm back on build 5 now, but if you'd like I will upgrade to build 6 again and double-check.

Changed 10 years ago by cjl

Changed 10 years ago by cjl

Changed 10 years ago by cjl

comment:3 Changed 10 years ago by cjl

Online update done from build 5 to 6 (thanks for making that work dsd!)

sudo olpc-update 13.1.0d_xo4-6

On first boot, I got a slightly different error presentation than before (no message that it would not start.), just return to Home view. There were errors logs though (see attached).

I went to Gnome to grab the logs (no network in Sugar to send them to myself) and then back.

After going back to Sugar, the activity started. very strange.

Changed 10 years ago by cjl

Changed 10 years ago by cjl

comment:4 Changed 10 years ago by godiard

The activity starts with a new instance, the problem is when try to read a previously saved document.

comment:5 Changed 10 years ago by godiard

  • Summary changed from Write-80 and Write-79 fail to start - XO-4b1 OS6 to Write-80 fail to start open a file

comment:6 Changed 10 years ago by godiard

  • Milestone changed from Unspecified by Release Team to 0.98

comment:7 Changed 10 years ago by godiard

I am trying to open abiword in a terminal, and crash too. a bt is attached.
Can be related to maliit?
After this crash, I did:

unset GTK_IM_MODULE

and run again abiword, but crashed with similar stacktrace.

Changed 10 years ago by godiard

bt running abiword in a terminal

comment:8 Changed 10 years ago by godiard

Garnacho propose the following patch:

diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
index 87120a4..edde978 100644
--- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
@@ -1754,6 +1754,9 @@ gint XAP_UnixFrameImpl::_imRetrieveSurrounding_cb (GtkIMContext *context,

PT_DocPosition begin_p, end_p, here;


+ if (!pView)
+ return FALSE;
+

begin_p = pView->mapDocPosSimple (FV_DOCPOS_BOB);
end_p = pView->mapDocPosSimple (FV_DOCPOS_EOB);
here = pView->getInsPoint ();

Changed 10 years ago by godiard

Changed 10 years ago by godiard

comment:9 Changed 10 years ago by godiard

Attached is the patch proposed by Carlos and a spec file similar to the last rpm from daniel [1] and this patch applied. Tried compiling on my xo-4, but could not finish by different problems.

[1] http://dev.laptop.org/~dsd/public_rpms/f18/abiword-2.9.3-1.git20121011.fc18.olpc2.src.rpm

comment:11 Changed 10 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Test with Write 81 and erikos rpm

comment:12 Changed 10 years ago by godiard

  • Keywords olpc-test-pending added

comment:13 Changed 10 years ago by cjl

Works for me on XO-4 B1 with build7

Reopened a document from Journal

comment:14 Changed 10 years ago by tonyforster

Works for me, V82 OS7 XO-4
thanks

comment:15 Changed 10 years ago by dsd

  • Keywords olpc-test-passed added; olpc-test-pending removed

Thanks for testing.

comment:16 Changed 9 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.