Ticket #4037: abiword.spec

File abiword.spec, 30.9 KB (added by godiard, 12 years ago)
Line 
1%define majorversion 2
2%define minorversion 9
3%define microversion 3
4
5Summary: The AbiWord word processor
6Name: abiword
7Version: %{majorversion}.%{minorversion}.%{microversion}
8Release: 1.git20121011%{?dist}.olpc2
9Epoch: 1
10Group: Applications/Editors
11License: GPLv2+
12
13# generated with svn export
14Source0: abiword-20121011.tar.gz
15
16Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
17Source11: abiword.mime
18Source12: abiword.keys
19Source13: abiword.xml
20URL: http://www.abisource.com/
21Requires: libabiword = %{epoch}:%{version}-%{release}
22
23%description
24AbiWord is a cross-platform Open Source word processor. It is full-featured,
25while still remaining lean.
26
27%package -n libabiword
28Summary: Library for developing applications based on AbiWord's core
29Group: System Environment/Libraries
30Requires: pygobject3
31Patch0: abiword-2.6.0-windowshelppaths.patch
32Patch1: abiword-2.8.3-desktop.patch
33Patch2: abiword-2.6.0-boolean.patch
34Patch3: abiword-plugins-2.6.0-boolean.patch
35
36# Make introspection work
37Patch4: introspection-fixes.patch
38Patch5: memory-allocator-confusion.patch
39Patch6: finish-introspection.patch
40Patch7: introspection-overrides-install.patch
41Patch8: init-noargs.patch
42
43# OLPC patch to add touch text handles
44Patch99: abiword-text-handles.diff
45
46# Avoid crash SL#4037
47Patch100: avoid-maliit-crash.patch
48
49
50BuildRequires: autoconf, libtool
51BuildRequires: desktop-file-utils
52BuildRequires: fribidi-devel, enchant-devel, wv-devel
53BuildRequires: zlib-devel, popt-devel, libpng-devel
54BuildRequires: gtk3-devel, libgsf-devel
55BuildRequires: boost-devel, t1lib-devel
56BuildRequires: dbus-glib-devel >= 0.70
57BuildRequires: readline-devel
58BuildRequires: bzip2-devel
59BuildRequires: poppler-devel >= 0.4.0
60BuildRequires: ots-devel >= 0.4.2
61BuildRequires: libwpd-devel >= 0.9.0
62BuildRequires: libwpg-devel
63BuildRequires: librsvg2-devel
64BuildRequires: libwmf-devel
65BuildRequires: aiksaurus-devel, aiksaurus-gtk-devel
66BuildRequires: link-grammar-devel >= 4.2.2
67BuildRequires: gtkmathview-devel >= 0.7.5, flex, bison
68BuildRequires: loudmouth-devel
69BuildRequires: asio-devel
70BuildRequires: libsoup-devel
71BuildRequires: gobject-introspection-devel, pygobject3
72
73%description -n libabiword
74Library for developing applications based on AbiWord's core.
75
76%package -n libabiword-devel
77Summary: Files for developing with libabiword
78Group: Development/Libraries
79Requires: libabiword = %{epoch}:%{version}-%{release}
80
81%description -n libabiword-devel
82Includes and definitions for developing with libabiword.
83
84%prep
85# setup abiword
86%setup -q -n abiword-20121011
87
88# patch abiword
89%patch1 -p1 -b .desktop
90%patch2 -p1 -b .boolean
91
92# patch abiword plugins
93#%patch3 -p1 -b .boolean
94%patch4 -p1
95%patch5 -p1
96%patch6 -p1
97%patch7 -p1
98%patch8 -p1
99
100%patch99 -p1
101%patch100 -p1
102
103# setup abiword documentation
104%setup -q -T -b 1 -n abiword-docs-%{version}
105%patch0 -p1 -b .windowshelppaths
106
107%build
108# build libabiword and abiword
109cd $RPM_BUILD_DIR/abiword-20121011
110# we need to update the generated configuration files because of patch104
111./autogen-common.sh
112autoreconf --force --install
113%configure --disable-static --enable-dynamic --enable-plugins --enable-clipart --enable-templates --enable-introspection
114make %{?_smp_mflags} V=1
115
116# build the documentation
117cd $RPM_BUILD_DIR/abiword-docs-%{version}
118ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/abiword ./make-html.sh
119
120%install
121
122# install abiword
123cd $RPM_BUILD_DIR/abiword-20121011
124%{__make} install DESTDIR=$RPM_BUILD_ROOT
125
126# install the documentation
127cd $RPM_BUILD_DIR/abiword-docs-%{version}
128mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help
129cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help/
130# some of the help dirs have bad perms (#109261)
131find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
132
133# finish up
134mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
135#cp $RPM_BUILD_DIR/abiword-%{version}/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
136
137cd $RPM_BUILD_DIR/abiword-20121011
138mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
139desktop-file-install --vendor fedora --add-category X-Fedora \
140  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
141  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
142  --add-category Applications --add-category Office \
143  ./abiword.desktop
144# remove the original one (which has X-Red-Hat-Base)  (#107023)
145%{__rm} -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
146
147%{__install} -p -m 0644 -D %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info/abiword.mime
148%{__install} -p -m 0644 -D %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/mime-info/abiword.keys
149%{__install} -p -m 0644 -D %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/mime/packages/abiword.xml
150
151# nuke .la files
152%{__rm} -f $RPM_BUILD_ROOT/%{_libdir}/libabiword-%{majorversion}.%{minorversion}.la
153%{__rm} -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{majorversion}.%{minorversion}/plugins/*.la
154
155%clean
156%{__rm} -rf $RPM_BUILD_ROOT
157
158%post
159update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
160update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
161
162%postun
163update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
164update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
165
166%files
167%defattr(-,root,root)
168%{_bindir}/abiword
169%{_datadir}/applications/*
170%{_datadir}/mime-info/abiword.mime
171%{_datadir}/mime-info/abiword.keys
172%{_datadir}/mime/packages/abiword.xml
173#%{_datadir}/pixmaps/*.png
174%{_datadir}/icons/hicolor/48x48/apps/abiword.png
175# Abiword help
176%{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord
177%{_mandir}/man1/abiword.1.gz
178
179%files -n libabiword
180%doc $RPM_BUILD_DIR/%{name}-20121011/COPYING $RPM_BUILD_DIR/%{name}-20121011/COPYRIGHT.TXT
181%{_libdir}/girepository-1.0/*.typelib
182%{python_sitearch}/gi/*
183%{_libdir}/libabiword-%{majorversion}.%{minorversion}.so
184%{_libdir}/%{name}-%{majorversion}.%{minorversion}
185%{_datadir}/%{name}-%{majorversion}.%{minorversion}
186# Abiword help - included in GUI app
187%exclude %{_datadir}/%{name}-%{majorversion}.%{minorversion}/AbiWord
188
189%files -n libabiword-devel
190%{_datadir}/gir-1.0/*.gir
191%{_includedir}/%{name}-%{majorversion}.%{minorversion}
192%{_libdir}/pkgconfig/%{name}-%{majorversion}.%{minorversion}.pc
193
194%changelog
195* Mon Feb 27 2012 Tom Callaway <spot@fedoraproject.org> - 1:2.8.6-17
196- fix build against modern glib, libpng
197
198* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.8.6-16
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
200
201* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1:2.8.6-15
202- Rebuild for new libpng
203
204* Tue Aug  9 2011 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-14
205- rebuild with link-grammar now its back
206
207* Tue Aug  2 2011 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-13
208- rebuild for new asio
209- drop obsolete OLPC and ARM includes
210
211* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-12
212- Fix a typo in the previous patch
213
214* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-11
215- Fix BZ 716005: --no-undefined is a linker flag, not a g++ flag
216
217* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-10
218- Mixed up the microversion and the release
219
220* Tue Aug 02 2011 Marc Maurer <uwog@abisource.com> - 1:2.8.6-9
221- Remove link-grammar from the BR and R until it is revived
222
223* Thu May 05 2011 Chris Tyler <chris@tylers.info> - 1:2.8.6-8
224- Excluded asio-devel from ARM builds
225
226* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.8.6-7
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
228
229* Thu Dec 30 2010 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-6
230- Rebuild for library soname bumps
231
232* Wed Dec  8 2010 Caolán McNamara <caolanm@redhat.com> - 1:2.8.6-5
233- Rebuild for libwpd 0.9
234
235* Wed Dec  8 2010 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-4
236- Rebuild for library soname bumps
237
238* Wed Sep 29 2010 jkeating - 1:2.8.6-3
239- Rebuilt for gcc bug 634757
240
241* Wed Sep 22 2010 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.6-2
242- Move abiword gui help from the library to the app. Fixes 578596
243
244* Sat Aug 14 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.6-1
245- New upstream release
246
247* Sat Jun 05 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.5-1
248- New upstream release
249
250* Fri Apr 16 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.4-1
251- New upstream release
252
253* Thu Apr 08 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.3-2
254- Update .desktop patch
255
256* Thu Apr 08 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.3-1
257- New upstream release
258
259* Tue Mar 02 2010 Marc Maurer <uwog@abisource.com> - 1:2.8.2-1
260- New upstream release
261- Package the man page
262
263* Wed Dec 23 2009 Rahul Sundaram <sundaram@fedoraproject.org> -1:2.8.1-4
264- Rebuild again since the wv soname bump was accidental
265- Remove superflous BuildRoot definitions and removals
266
267* Mon Dec 21 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.8.1-3
268- Rebuild against new libwv
269
270* Sun Nov 01 2009 Marc Maurer <uwog@abisource.com> - 1:2.8.1-2
271- Rebuild
272
273* Sun Nov 01 2009 Marc Maurer <uwog@abisource.com> - 1:2.8.1-1
274- New upstream release
275
276* Tue Sep 01 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.10-2
277- Unconditionally add the dbus-glib-devel BR since the AbiCollab
278  Sugar backend is now always compiled in, even on non-OLPC
279  platforms.
280
281* Sat Aug 29 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.10-1
282- New upstream release
283
284* Mon Aug 24 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.9-2
285- Make abiword depend on libabiword
286
287* Sun Aug 23 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.9-1
288- New upstream version
289
290* Tue Aug 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1:2.7.8-2
291- drop Req: mathml-fonts (dep moved to gtkmathview)
292
293* Sun Aug 02 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.8-1
294- New upstream version
295
296* Mon Jul 27 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.7-3
297- Rerun autogen.sh after changing the makefiles
298
299* Mon Jul 27 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.7-2
300- Add a patch to work around a templates makefile bug
301
302* Mon Jul 27 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.7-1
303- New upstream release
304- Add --enable-dynamic to configure so plugins link against libabiword.so
305
306* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.7.6-4
307- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
308
309* Sun Jul 05 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.6-3
310- Re-add updated .desktop patch
311
312* Sun Jul 05 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.7.6-2
313- Remove old patch
314
315* Sun Jul 05 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.7.6-1
316- New upstream release
317
318* Fri Jun 26 2009 Peter Robinson <pbrobinson@gmail.com> - 1:2.7.5-3
319- Drop old dependencies. Fixes bug 506023
320
321* Sun Jun 21 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.5-2
322- Package unpackaged icon
323
324* Fri Jun 19 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.5-1
325- New upstream release
326
327* Fri Jun 19 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.4-2
328- Add libsoup-devel BR
329- Remove version from asio-devel BR
330- Add libwpg-devel BR
331- Register the .abicollab extension and mimetype
332
333* Thu Jun 11 2009 Marc Maurer <uwog@abisource.com> - 1:2.7.4-1
334- New upstream release
335
336* Mon Mar 09 2009 Marc Maurer <uwog@abisource.com> - 1:2.6.8-2
337- Make g++ 4.4 and rindex friends again
338
339* Mon Mar 09 2009 Marc Maurer <uwog@abisource.com> - 1:2.6.8-1
340- New upstream release
341
342* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.6.6-10
343- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
344
345* Sat Jan 10 2009 Marc Maurer <uwog@abisource.com> - 1:2.6.6-1
346- New upstream release
347
348* Sun Nov 23 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.5-1
349- New upstream release
350
351* Thu Nov 20 2008 Peter Robinson <pbrobinson@gmail.com> - 1:2.6.4-9
352- Remove unused script to drop perl dependency
353
354* Fri Sep 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:2.6.4-8
355- add t1lib-devel to BuildRequires, fixes FTBFS
356
357* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-7
358- Fix libabiword-devel requires
359
360* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-6
361- Drop explicit libabiword requires
362
363* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-5
364- Fix typo in patch name
365
366* Mon Jul 21 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-4
367- Merge with the OLPC-3 branch
368
369* Sun Jul 13 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-3
370- We don't include ispell_dictionary_list.xml anymore, so no
371  need to ghost it
372
373* Sun Jul 13 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-2
374- Update patches to apply without fuzz
375
376* Sun Jul 13 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.4-1
377- New upstream release
378
379* Thu May 01 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.3-1
380- New upstream release
381
382* Sun Apr 06 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.2-1
383- New upstream release
384
385* Sun Apr 06 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.1-1
386- New upstream release
387
388* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-6
389- Don't forget to cvs add nextgen.sh
390
391* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-5
392- Include nextgen.sh as abiword-plugins it's a proper autoconf project
393- Fix 439396: abiword includes its own dictionary?
394- Don't build libabiword, it's broken; re-enable it when we release
395  abiword 2.8, which generates a proper library
396- Drop aspell-devel BR
397
398* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-4
399- Don't forget to reautogen after changing the plugin build system
400
401* Sat Mar 29 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-3
402- Fix 439395: apply patch to remove any runtime dependency on boost
403
404* Fri Mar 28 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-2
405- Add BigEndian32.american.hash that was missing from the disted
406  abiword-extras tarball
407
408* Tue Mar 25 2008 Marc Maurer <uwog@abisource.com> - 1:2.6.0-1
409- New upstream release
410- Split off an experimental devel package
411
412* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:2.4.6-8
413- Autorebuild for GCC 4.3
414
415* Tue Jan 29 2008 Michel Salim <michel.sylvan@gmail.com> - 1:2.4.6-7
416- Update license field
417- Remove build deps on g++ and libstdc++ (in minimum build environment)
418- Remove .cvsignore files from installed doc; fix abw2html.pl permission
419- Add support for goffice-0.6 when building on Fedora 9 and above
420- Fix for F9 glibc lacking TRUE and FALSE
421
422* Tue Sep 04 2007 Lubomir Kundrak <lkundrak@redhat.com> - 1:2.4.6-6.fc7
423- Fix 248103
424
425* Fri Apr 06 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-5.fc7
426- Rebuild
427
428* Fri Apr 06 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-4.fc7
429- Fix 234765
430
431* Tue Feb 20 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-3.fc7
432- Fix 181799
433
434* Fri Feb 02 2007 Marc Maurer <uwog@abisource.com> - 1:2.4.6-2.fc7
435- Rebuild
436
437* Sun Nov 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.6-1.fc7
438- Update to 2.4.6
439
440* Thu Oct 12 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-4.fc6
441- Fix bug 207294
442
443* Mon Sep 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-3.fc6
444- Rebuild for FC6
445
446* Sat Jul 22 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-2.fc6
447- Fix http://bugzilla.abisource.com/show_bug.cgi?id=10229
448
449* Sun Jul 09 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.5-1.fc6
450- Update to 2.4.5
451- Fix bug 196690 - abiword fails to build in mock with minimal
452  build environment
453- Drop the document build patch
454
455* Tue Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
456- Fix documentation generation
457- Fix charting support
458
459* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
460- New upstream version
461- Remove the macro patch and update the desktop patch
462
463* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
464- Rebuild
465
466* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
467- Disable the collaboration plugin; it is not working in 2.4.x
468
469* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
470- Rebuild for Fedora Extras 5
471
472* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
473- bug 171926
474
475* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
476- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
477  headers anymore
478
479* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
480- Remove redundant requires - bug 177305
481
482* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
483- Bump release, forgot to add desktop patch
484
485* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
486- Update to 2.4.2
487- Add BuildRequires readline-devel for the AbiCommand plugin
488- Add BuildRequires bzip2-devel and poppler-devel for plugins
489- Update desktop patch
490- Patch to fix plugin marcros
491
492* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
493- Fix bug 171928
494
495* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
496- Fix bug 161832: "Abiword is not loading certain modules"
497- Add libgsf dependecy, which was needed all along
498- Disable the collaboration plugin, it is not for general use at all
499
500* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
501- Use %%{?dist} in the release name
502
503* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
504- Update to 2.4.1
505
506* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
507- Require mathml-fonts
508- Don't rerun autogen.sh, no need anymore
509- Update gtkmathview dependency to 0.7.5
510- Update to 2.4.0
511
512* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
513- Fix gtkmathview BuildRequires
514
515* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
516- Update to 2.3.99
517
518* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
519- Update to 2.3.6
520- Drop the pango patch
521
522* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
523- Rebuild
524
525* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
526- Enable the abimathview plugin
527
528* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
529- Update to 2.3.5
530
531* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
532- Update the pango patch to disable more pango code
533
534* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
535- Fix the build after applying the pango disabling patch by
536  rerunning autogen.sh
537
538* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
539- Disable the experimental pango renderer
540
541* Thu Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
542- Update to 2.3.4
543- Add link-grammar dependency
544
545* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
546- Update to 2.2.9
547- Drop the mailmerge patch again
548
549* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
550- Fix build with mailmerge patch
551
552* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
553- Update to 2.2.8
554
555* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
556- rebuild on all arches
557
558* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
559- Because we love brown paper bag releases
560
561* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
562- Drop the gcc4, wvread, virtdestr and pt64 patches
563- Update the desktop patch
564
565* Fri Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
566- Fix 64bit build
567- Add virtual destructors to classes with virtual functions
568
569* Fri Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
570- Remove the --disable-magick plugin switch
571- disable GDA support until the plugin is ported to gnomedb 1.2.x
572- Change the download location from SF to http://www.abisource.com/
573- patch libole2
574- fix read as a macro in new glibc
575
576* Fri Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
577- bump to latest stable
578- drop integrated dashboard patch again
579- some gcc4 fixes
580
581* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
582- rh#149447# dashboard spam revisited
583
584* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
585- bump to latest stable version
586- drop integrated nautilus depend patch
587- drop integrated libwpd depend patch
588
589* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
590- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
591
592* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
593- rebuild
594
595* Mon Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
596- remove unneccessary nautilus dependency
597
598* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
599- bump to new version
600- drop integrated silenceabidash patch
601
602* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
603- RH#145085# annoying cluepacket message on stdout/stderr
604
605* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
606- Rebuilt for new readline.
607
608* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
609- RH#143368# use enchant as spellchecker
610
611* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
612- bump to new version
613
614* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
615- bump to new version
616- geometry patch upstreamed
617- security patch upstreamed
618- removeoledecod patch upstreamed
619- regenerate desktop patch
620
621* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
622- #abi7961# remove tempnam usages
623
624* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
625- bump to latest major stable version
626- #rh140321# sanity check geometry
627
628* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
629- bump to latest stable version
630
631* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
632- rebuild for python 2.4
633
634* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
635- Change to PreReq instead of Requires(post), up to 0.9
636
637* Thu Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
638- Better Requires desktop-file-utils
639
640* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
641- update to new abiword, + change norwegian wordprocessor translation
642
643* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
644- #132389# Add more abiword supported mime types to abiword.desktop
645
646* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
647- merge abiword.keys into abiword.desktop
648
649* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
650- 2.0.11
651
652* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
653- use libgnomedb
654
655* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
656- 2.0.10
657- use aiksaurus
658
659* Tue Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
660- rebuilt
661
662* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
663- #126012# some desktop translations
664
665* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
666- #128004# fix irritating windows looking filenames for generated pngs
667
668* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
669- 2.0.9, new version with security fix
670
671* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
672- rebuilt
673
674* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
675- 2.0.7, new version + gcc34 fixes
676
677* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
678- 2.0.6, 64bit changes made upstream
679
680* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
681- 2.0.5
682
683* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
684- rebuilt
685
686* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
687- rebuild for newer libots and libwpd
688- fix verify as non-root (#109261)
689- add wpd files to abiword.keys (#114907)
690
691* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
692- rebuilt
693
694* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
695- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
696
697* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
698- rebuild for new libwpd
699
700* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
701- and librsvg2-devel (#111222)
702
703* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
704- buildrequire libgnomeui-devel (#111164)
705
706* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
707- 2.0.1
708- really remove duplicate desktop file
709
710* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
711- make the docs with the just built abiword so that we don't have to
712  have abiword installed to build the docs (#107279)
713
714* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
715- fix linkage to glib 1.2 in hancom plugin (#106033)
716
717* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
718- add %%clean specfile target
719
720* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
721- remove duplicate desktop file (#107023)
722
723* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
724- include the help
725- show the clipart (#104577)
726
727* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
728- rebuild with newer libwpd and libots to get those plugins
729
730* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
731- 2.0.0
732
733* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
734- 1.99.6
735
736* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
737- 1.99.5
738
739* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
740- 1.99.3
741- put icon in the right place (#101646)
742- fix some 64bit casting issues
743- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
744- disable -pedantic -ansi so that it will build
745
746* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
747- ugly hack to deal with libtool silliness on x86_64
748
749* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
750- 1.99.2
751- add buildrequires to make sure the ots and wp plugins get built
752- no longer needs libgal2, remove buildrequires
753
754* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
755- 1.99.1
756
757* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
758- rebuilt
759
760* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
761- rebuild for new libgal2
762
763* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
764- tweak plugins build
765
766* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
767- 1.9.1
768- drop old patches, switch to using autoconf based build system instead
769  of diving makefiles
770- build with gnome support
771- build with plugins
772- add patch to build on AMD64
773
774* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
775- rebuild to fix broken libpspell dep
776
777* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
778- 1.0.5
779
780* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
781- fix for abiword starting off the screen (#82425)
782
783* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
784- 1.0.4
785
786* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
787- rebuilt
788
789* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
790- make it build on x86_64
791
792* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
793- 1.0.3 (#80560)
794- set umask before running mkfontdir in %%post
795- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
796
797* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
798- Fix doc lines
799- Fix multilib
800
801* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
802- rebuilt with gcc-3.2 (we hope)
803
804* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
805- fix help index symlink (#71219)
806
807* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
808- add abiword binary symlink for upstream compatibility (#70267)
809
810* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
811- rebuild using gcc-3.2-0.1
812
813* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
814- use included desktop file (#64447)
815- use desktop-file-install
816
817* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
818- 1.0.2
819- disable perl module build since we weren't including it anyway
820
821* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
822- 1.0.1
823
824* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
825- zh_CN and zh_TW fonts.dir were flipped
826- update to 0.99.5 as it fixes some major bugs
827- define ABI_BUILD_VERSION so the about screen gives us a version
828
829* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
830- 1st try at fixing up CJK (#61590)
831- #if 0'ify font warning dialog (#62909, #64556)
832
833* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
834- Update to 0.99.4, fixes #61153
835- Fix #61344
836- Nuke the warning about being unable to add anything to font path,
837  that's not how xfs works.
838
839* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
840- 0.99.2
841- remove blank lines in fonts.dir
842
843* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
844- 0.99.1
845
846* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
847- Added patch to use libpng10
848- Added patch to fix perl build problems.
849
850* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
851- 0.9.5
852
853* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
854- Update to 0.9.4.1 (RFE #54806)
855- Add URL (RFE #54590)
856
857* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
858- Fix uninstall (#49350)
859
860* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
861- rebuilt so that dirs aren't sgid root
862
863* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
864- Add build requirements (#45157)
865
866* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
867- Remove CVS admin files from documentation (#44916)
868
869* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
870- add s390x patch from <oliver.paukstadt@millenux.com>
871
872* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
873- add s390 patch from Helge Deller
874
875* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
876- Update to 0.7.14
877
878* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
879- Handle MIME type stuff (Bug #27530)
880- Add BuildPrereqs for some of the less common stuff AbiWord uses
881  (gal-devel, gnome-print-devel, libunicode-devel)
882
883* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
884- 0.7.13
885
886* Mon Jan 15 2001 Than Ngo <than@redhat.com>
887- fixed broken code for building
888
889* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
890- 0.7.12
891- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
892
893* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
894- Rebuild to get rid of 0777 dirs
895
896* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
897- 0.7.11
898
899* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
900- fix path to chkfontpath, it was wrong.
901
902* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
903- Up Epoch and release
904
905* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
906- Don't ship AbiWord_s if we have AbiWord_d
907- Register AbiWord's fontpath with xfs
908
909* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
910- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
911  change the ABI without increasing the soname!
912- fix tooltip (Bug #14711)
913- move binaries from /usr/share to /usr/lib
914
915* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
916- Fix build on ia64.
917
918* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
919- automatic rebuild
920
921* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
922- Rebuild with new gcc.
923
924* Sat Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
925- Fix build on ia64
926
927* Fri Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
928- 0.7.10
929- update download location
930
931* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
932- initial build for main CD
933- clean up specfile
934- fix build with gcc 2.96 and glibc 2.2
935- exclude ia64 for now
936
937* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
938- 0.7.9
939
940* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
941- 0.7.8
942- move the desktop file to /etc/X11/applnk so it can be used in both
943  GNOME and KDE
944- fix up handling of RPM_OPT_FLAGS
945
946* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
947- bzipped source to conserve space.
948
949* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
950- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
951- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
952
953* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
954- 0.7.7
955- handle RPM_OPT_FLAGS
956
957* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
958- first build for inclusion into Powertools.
959- some things in this spec file are from the abisuite-0.7.5-1mdk package