Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2050 closed defect (fixed)

ctrl c ctrl v disabled

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: 0.88.x
Severity: Unspecified Keywords:
Cc: rgs, alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

xo-1 running os240py or os258py, ctrl c,v do not work but copy and paste from toolbar do. (can get one only ctrl v after copying with toolbar.) Fails in Gnome too.

Attachments (1)

hack-accelerators.patch (485 bytes) - added by rgs 9 years ago.
the attached patch makes ctrl-{c,v} by expanding/un-expanding the edit toolbar on startup

Download all attachments as: .zip

Change History (12)

comment:1 follow-up: Changed 9 years ago by tonyforster

TA95 OS373pyg

Launch TA
select a block
ctrl c and v do not work
copy using the toolbar
ctrl c and v now work

comment:2 Changed 9 years ago by walter

  • Cc rgs added

Raul and I have been trying to chase this one down for a long time... something t do with how I am setting up the toolbars.

comment:3 in reply to: ↑ 1 Changed 9 years ago by rgs

Replying to tonyforster:

TA95 OS373pyg

Launch TA
select a block
ctrl c and v do not work
copy using the toolbar
ctrl c and v now work

I believe the ctrl-{c,v} accelerators become available once the copy/paste toolbar becomes visible. A shorter path of your procedure also works:

  • Launch TA
  • select a block
  • ctrl c and v do not work
  • activate copy/paste toolbar
  • ctrl c and v now work

which suggests a few hacks to fix this. Finding why the accelerators are not responding as early as everything is running is the true question though.

comment:4 Changed 9 years ago by rgs

Plus, forcing the use of the old toolbars (adding self.new_sugar_system = False in TurtleArtActivity.py#723) makes ctrl-{c,v} work.

Changed 9 years ago by rgs

the attached patch makes ctrl-{c,v} by expanding/un-expanding the edit toolbar on startup

comment:5 follow-up: Changed 9 years ago by sascha_silbe

Terminal has the same issue (#1784); maybe this should be reassigned to sugar-toolkit?

comment:6 in reply to: ↑ 5 Changed 9 years ago by rgs

Replying to sascha_silbe:

Terminal has the same issue (#1784); maybe this should be reassigned to sugar-toolkit?

Note that behavior seems to be identical to the one seen in Turtle Art (i.e.: accelerators start responding once you've enabled the edit toolbar).

Might be sugar-toolkit or all activities are building toolbars in a wrong way?

comment:7 follow-up: Changed 9 years ago by rgs

Do we know of any activity using the new toolbars in which the accelerators of the edit buttons do work?

comment:8 Changed 9 years ago by garycmartin

  • Cc alsroot added

I'm sure this was broken when the new toolbars were implemented, and then fixed by alsroot, perhaps somethings reverted that work. Sorry don't have the trac to hand. Alsroot, does this ring any bells for you?

comment:9 in reply to: ↑ 7 Changed 9 years ago by tonyforster

Replying to rgs:

Do we know of any activity using the new toolbars in which the accelerators of the edit buttons do work?

OS373pyg
ctrl c works ok for
abacus
speak
calculate
paint
log
pippy
write
browse

with record, take a photo, click it, the first ctrl c does nothing, second one ok

comment:10 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Work around incorporated in v95 (We can continue to track the Sugar issue in #1784)

See http://git.sugarlabs.org/projects/turtleart/repos/mainline/commits/ce7d339372bc86b5da97fb6683f06fb882fd44aa

comment:11 Changed 9 years ago by alsroot

I've create #2220

Note: See TracTickets for help on using tickets.