Opened 10 years ago

Closed 6 years ago

#2220 closed defect (fixed)

Accelerators doesn't work if toolitems are in sub-pallete in ToolbarBox

Reported by: alsroot Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.88.x
Severity: Unspecified Keywords: r?
Cc: walter Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

See original #2050 issue.
The problem is that accelerators don't work if toolitems are in subpalete (not expanded).

Attachments (1)

0001-Accelerators-doesn-t-work-if-toolitems-are-in-sub-pa.patch (3.2 KB) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by walter

  • Cc walter added

comment:2 Changed 10 years ago by alsroot

  • Keywords r? added

In my mind, we can use workaround fix (ToolbarButton update accelerators on every its hierarchy change) since we are before 0.90 release.

Not sure what the best fix could be. Maybe keeping all sub toolbars all time in ToolbarBox and move them to palette when it is needed, but it requires move invasive changes in code.

comment:3 Changed 10 years ago by tonyforster

see #1784 #2050

comment:4 Changed 7 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:5 Changed 6 years ago by tch

  • Resolution set to fixed
  • Status changed from new to closed

The patch mentioned in this ticket never landed, but accelerators seem to work properly in activities such as Terminal (42.1) and Browse (156).

I tested using Sugar 0.101.6 (Australian build 34003xx4 with an XO-4).

Note: See TracTickets for help on using tickets.