Opened 11 years ago

Closed 11 years ago

#2051 closed defect (fixed)

[PATCH] Measure leaks file descriptors

Reported by: lmacken Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: patch
Cc: lmacken@… Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When saving screenshots, Measure creates a temporary directory and removes it when it is done, but does not close the file descriptor.

Since we're not dealing with 'file' objects directly, we can't rely on the garbage collector to clean up after us.

Attachments (1)

0001-Ensure-that-we-close-the-file-descriptors-of-our-tem.patch (1.0 KB) - added by lmacken 11 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 11 years ago by lmacken

  • Cc lmacken@… added

comment:2 Changed 11 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Added to and tested with Measure-30 (See #1070)

Note: See TracTickets for help on using tickets.