Opened 7 years ago

Closed 6 years ago

#3834 closed defect (wontfix)

Journal doesn't follow symlinks

Reported by: humitos Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: erikos, manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

  1. Create a directory under /tmp, "test" for example
    mkdir /tmp/test
    
  2. Copy some files (pdf, audio, scripts, anything) inside /tmp/test
  3. Make a symlink to this folder under ~/Documents
    cd ~/Documents
    ln -s /tmp/test .
    
  4. Run Sugar
  5. Go to the Journal
  6. Click "Documents" icon at the bottom

Issue:

Your files under /tmp/test do not appear in the Journal list.

Expected behaviour:

Show the files under /tmp/test


I found this topic was already discussed here[1] and a patch was applied here[2] but I think there is a bug on this patch because of this that I'm reporting here.

I'm uploading a patch that allow symlinks to be followed but I'd like to improve it because it doesn't contemplate all the cases.

[1] http://dev.laptop.org/ticket/10140
[2] http://git.sugarlabs.org/sugar/mainline/commit/c4faafd51c63bf19e14f23b710d310269dff4b07

Attachments (1)

allow-symlinks.diff (582 bytes) - added by humitos 7 years ago.
This patch is not a solution, but it shows how it should work

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by humitos

This patch is not a solution, but it shows how it should work

comment:1 Changed 7 years ago by humitos

Those symlinks that point to some folder inside self._mount_point are allowed in the original version of Sugar, but it is useless because that folder is going to be read anyway (because of the recursive reader)

comment:2 Changed 6 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed

Imo, this is not important enough to fix. Patches would be welcome of course, but I don't think we should track it.

Note: See TracTickets for help on using tickets.