Opened 10 years ago

Closed 8 years ago

#3080 closed defect (duplicate)

Cannot override a system-installed activity with another bundle

Reported by: sascha_silbe Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords:
Cc: garycmartin Distribution/OS:
Bug Status: New

Description

When trying to downgrade a system-installed activity by "resuming" an older bundle from the Journal, there's no visible reaction in the Journal (no downgrade alert), but the following exception in shell.log:

1315162453.556646 DEBUG root: get_file asked for entry with id dbus.ByteArray('e971fa24-59aa-429a-a9e7-ff3bffe92ad9', variant_level=1)
1315162453.571456 DEBUG root: TempFilePath created dbus.String(u'/home/sascha.silbe/.sugar/default/data/e971fa24-59aa-429a-a9e7-ff3bffe92ad9-18445069-d7e4-450d-b9cb-3447
c553685c_NtqeqT.xo')
1315162453.594111 DEBUG root: Upgrading activity bundle
1315162453.594877 WARNING root: Unable to uninstall system activity, installing upgraded version in user activities
1315162453.599186 ERROR root: Traceback (most recent call last):
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/journal/listview.py", line 544, in __icon_clicked_cb
    misc.resume(metadata)
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/journal/misc.py", line 188, in resume
    registry.upgrade(bundle)
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/model/bundleregistry.py", line 443, in upgrade
    self.install(bundle)
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/model/bundleregistry.py", line 376, in install
    raise AlreadyInstalledException
AlreadyInstalledException

Change History (3)

comment:1 Changed 10 years ago by FGrose

  • Cc garycmartin added
  • Summary changed from Cannot override a system-installed activity with an older bundle to Cannot override a system-installed activity with another bundle

Confirmed with SoaS as well, since Strawberry (sugar 0.84)

I found that if an activity is installed in ~/Activities, it may be updated or
downgraded, even when there is an installation in /usr/share/sugar/activities.
(So, copying the ActivityName.activity folder to ~/Activities directory is a work-around.)

Besides version management coding, we need some more design ideas on keeping this
from getting too confusing.

comment:2 Changed 10 years ago by FGrose

#2164 says this behavior is fixed with a confirmation dialog.
This I can confirm on os5 with an XO-1.75, but see new comments in #2164 for Sugar in a Window.

comment:3 Changed 8 years ago by dnarvaez

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.