Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2615 closed defect (fixed)

Dextrose, browse115 fails on dialog box, os439dg

Reported by: tonyforster Owned by: lucian
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords: dextrose
Cc: sridhar Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

/home/olpc/Activities/Browse.activity/webtoolbar.py:163: DeprecationWarning: integer argument expected, got float

path, col_, x_, y_ = view.get_path_at_pos(event.x, event.y)

/home/olpc/Activities/Browse.activity/webtoolbar.py:69: GtkWarning: gtk_entry_set_text: assertion `text != NULL' failed

self.props.text = text

1297731632.040788 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <hulahop.webview._Chrome instance at 0xa1f55cc>
1297731632.046694 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <XPCOM component '<unknown>' (implementing nsIWebBrowser)>
/usr/lib/python2.6/site-packages/hulahop/webview.py:56: Warning: invalid uninstantiatable type (null)' in cast to GtkWidget'

self.web_view.get_toplevel().destroy()

/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

self.web_view.get_toplevel().destroy()

/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

self.web_view.get_toplevel().destroy()

Gdk-ERROR : The program 'sugar-activity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.

(Details: serial 97618 error_code 150 request_code 144 minor_code 7)
(Note to programmers: normally, X errors are reported asynchronously;

that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

aborting...
Terminated by signal 6, pid 2684 data (None, <open file '<fdopen>', mode 'w' at 0x8e0cf70>, dbus.ByteArray('1d2e53e581ec0e65e931f120f479887e59b39f88', variant_level=1))

Change History (18)

comment:1 Changed 8 years ago by RafaelOrtiz

This must be tested with newer versions of browse.

comment:2 Changed 8 years ago by tonyforster

also fails on browse 120

comment:3 Changed 8 years ago by lucian

Could you please describe in what conditions this happens?

From the log, it looks like the old-standing bug that breaks a lot of windowing-related code. A reference is lost across the gtk-xulrunner bridge and None is used as a widget (I think).

comment:4 Changed 8 years ago by tonyforster

When in webmail I get a dialog box to confirm mail deletion, "are you sure you want to delete these messages" clicking OK or Cancel crashes

comment:5 Changed 8 years ago by tonyforster

I should have added that I think the webmail is using frames

comment:6 Changed 8 years ago by lucian

Could you please do "save complete page" in Firefox on that page, right before the dialog would appear?

comment:7 Changed 8 years ago by tonyforster

as this is my private webmail, can we do this offline please?
forster at ozonline dot com dot au

comment:8 Changed 8 years ago by lucian

I had a look at code and it doesn't do anything out of the ordinary.

Browse should survive a confirm in an "onclick". When I have time I'll do a through review of all windowing code in Browse, to also possibly fix http://bugs.sugarlabs.org/ticket/2155

comment:9 Changed 8 years ago by tonyforster

maybe relevant to #2155 though this is experience on V108
When using v108 on 367OLPC AU
webmail lite, which you have files for, does not display the confirmation dialog at all
horde webmail, presumably the same as #2155 can delete mail but not write new, the window appearing as neither a new tab nor a new window

comment:10 Changed 8 years ago by lucian

The interaction between GTK and xulrunner has always been a bit fragile, and this is obviously an instance of that. Probably some ownership issue between the two systems, so GTK ends up trying to use a null object.

Fwiw, this is not an issue in Surf (webkit version of Browse), but that isn't yet ready, mainly because it depends on bleeding-edge packages.

comment:11 Changed 8 years ago by sridhar

  • Cc sridhar added

comment:12 Changed 8 years ago by sridhar

I've added lots of detail at https://dev.laptop.org.au/issues/472

It looks like a problem with the underlying libraries rather than with Browse.

This is a critical bug for OLPC Australia, as Australian schools require dialogue boxes to authenticate against the http proxy. Without this, Browse cannot get onto the Web.

comment:13 Changed 8 years ago by RafaelOrtiz

I've tested this with browse at git and is not failing on about:config dialogs,
the example that you mention in the .au bug.

comment:14 follow-up: Changed 8 years ago by tonyforster

git? about:config?

I would need more information to test these cases

I can confirm that Browse is unusable on some websites with popups and dialogs for those OS versions which do not support tabs

comment:15 Changed 8 years ago by sridhar

Dialogue boxes work in Browse 122 on XO-AU 10.1.3-au2.

comment:16 in reply to: ↑ 14 Changed 8 years ago by RafaelOrtiz

Replying to tonyforster:

git? about:config?

I would need more information to test these cases

I'm using browse directly from the code on git , the about:config dialogs are the ones used to set default preferences for Browse, you have to visit about:config directly on
the URL box.

I can confirm that Browse is unusable on some websites with popups and dialogs for those OS versions which do not support tabs

comment:17 Changed 8 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

As Sridhar confirms this is not reproducible now, closing. (please re-open if it happens in specific web pages).

comment:18 Changed 8 years ago by tonyforster

Tested V122 on OS 861au
all OK

Note: See TracTickets for help on using tickets.