Opened 9 years ago

Closed 6 years ago

#2155 closed defect (obsolete)

Browse-115 stops when pop-up tab closes

Reported by: christophd Owned by: lucian
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: hulahop Version: 0.88.x
Severity: Unspecified Keywords: Dextrose
Cc: m_anish, sridhar, ebordon Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

My university's webmail system (Horde) uses a popup for composing e-mails which Browse-115 correctly displays in a tab. However upon sending the e-mail not just the composition tab is closed but the whole Browse activity quits.

I have been consistently able to reproduce this on my XO-1 running build 353pyg and Browse-115.

Cairo version:

cairo-1.8.8-1.fc11.i586

Browse log:

/home/olpc/Activities/Browse.activity/webactivity.py:26: DeprecationWarning: the sha module is deprecated; use the hashlib module instead

import sha

returning /home/olpc/.sugar/default/org.laptop.WebActivity/data/gecko/prefs.js for key NS_APP_PREFS_50_FILE
1281485529.468977 WARNING root: .has_key() is deprecated, use 'in'
1281485530.215058 WARNING root: No gtk.AccelGroup in the top level window.
1281485530.254288 WARNING root: No gtk.AccelGroup in the top level window.
1281485530.462426 WARNING root: No gtk.AccelGroup in the top level window.
1281485530.506957 WARNING root: No gtk.AccelGroup in the top level window.
1281485530.566313 WARNING root: No gtk.AccelGroup in the top level window.
1281485530.592393 WARNING root: No gtk.AccelGroup in the top level window.
/usr/lib/xulrunner-1.9.1/python/xpcom/init__.py:54: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6

self.message = message

(sugar-activity:3013): DEBUG: Got client ID "1097f2008c4ca8dc5128148553380484700000018290001"
(sugar-activity:3013): DEBUG: Setting initial properties
(sugar-activity:3013): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:3013): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
(sugar-activity:3013): DEBUG: Received SaveComplete message in state save-yourself-done
/home/olpc/Activities/Browse.activity/webtoolbar.py:69: GtkWarning: gtk_entry_set_text: assertion `text != NULL' failed

self.props.text = text

1281485792.947926 WARNING root: No gtk.AccelGroup in the top level window.
1281485793.015581 WARNING root: No gtk.AccelGroup in the top level window.
1281485793.018288 WARNING root: No gtk.AccelGroup in the top level window.
1281485793.172707 WARNING root: No gtk.AccelGroup in the top level window.
1281485793.175616 WARNING root: No gtk.AccelGroup in the top level window.
1281485793.178127 WARNING root: No gtk.AccelGroup in the top level window.
/usr/lib/python2.6/site-packages/hulahop/webview.py:56: Warning: invalid uninstantiatable type (null)' in cast to GtkWidget'

self.web_view.get_toplevel().destroy()

/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

self.web_view.get_toplevel().destroy()

/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

self.web_view.get_toplevel().destroy()

/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gdk_x11_visual_get_xvisual: assertion `visual != NULL' failed

self.web_view.get_toplevel().destroy()

Traceback (most recent call last):

File "/home/olpc/Activities/Browse.activity/webtoolbar.py", line 438, in _reload_session_history

for menu_item in palette.menu.get_children():

AttributeError: 'NoneType' object has no attribute 'menu'
Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/gtk-2.0/gobject/init.py", line 108, in obj_set_property

prop.setter(self, value)

File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 365, in set_active

self.save()

File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 600, in save

preview = self.get_preview()

File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 548, in get_preview

width, height = pixmap.get_size()

AttributeError: 'NoneType' object has no attribute 'get_size'

Attachments (3)

browse-crash.tar.gz (3.4 KB) - added by carrott 9 years ago.
logs from browse crashing and refusing to start
browse-1.log (31.9 KB) - added by lucian 9 years ago.
browse-2.log (12.5 KB) - added by lucian 9 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 9 years ago by m_anish

  • Cc m_anish added

comment:2 Changed 9 years ago by dfarning

  • Keywords Dextrose added

comment:3 Changed 9 years ago by carrott

Reproduced by a 9 year old!!

Reproduced on os300py and os373pyg. Attached browse-crash.tar.gz log files from os373pyg

Changed 9 years ago by carrott

logs from browse crashing and refusing to start

comment:4 Changed 9 years ago by seeta

  • Status changed from new to assigned

comment:5 Changed 9 years ago by bernie

We've already seen this: Browse occasionally crashes when closing tabs.

Seems to be a bug in xulrunner, or gtk. We thought that Fedora 11 wasn't affected, but apparently it is.

comment:6 Changed 9 years ago by lucian

Looks like a bug in hulahop so far. It seems like it's trying to destroy something that isn't a window. Hulahop was probably not designed with tabs in mind.

Changed 9 years ago by lucian

Changed 9 years ago by lucian

comment:7 follow-up: Changed 9 years ago by smparrish

Lucian would you mind reporting this to upstream hulahop and see what kind of feedback you get. Thanks

comment:8 in reply to: ↑ 7 Changed 9 years ago by sascha_silbe

  • Component changed from Browse to hulahop

Replying to smparrish:

Lucian would you mind reporting this to upstream hulahop and see what kind of feedback you get. Thanks

Done. ;)
(Sugar Labs is upstream for hulahop)

comment:9 Changed 8 years ago by trebot

I flashed my XO-1 with os437dg today. Browse 115 has a problem in that it crashes after you dismiss a popup. On clicking ok on a popup such as the one you get from a log in screen or to submit a request for a developer key Browse crashes. This is 100% repeatable.
Here is the log output

/home/olpc/Activities/Browse.activity/webactivity.py:26: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
/usr/lib/xulrunner-1.9.1/python/xpcom/__init__.py:54: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  self.message = message
Registering '@mozilla.org/module-loader/python;1' (libpyloader.so)
Registering '@mozilla.org/network/protocol/about;1?what=python' (pyabout.py)
returning /home/olpc/.sugar/default/org.laptop.WebActivity/data/gecko/prefs.js for key NS_APP_PREFS_50_FILE
1295182887.680465 WARNING root: Not enabling the multiple tabs feature due to a bug in cairo/mozilla
1295182887.926222 WARNING root: No gtk.AccelGroup in the top level window.
1295182887.984340 WARNING root: No gtk.AccelGroup in the top level window.
1295182888.211873 WARNING root: No gtk.AccelGroup in the top level window.
1295182888.256695 WARNING root: No gtk.AccelGroup in the top level window.
1295182888.337227 WARNING root: No gtk.AccelGroup in the top level window.
1295182888.363153 WARNING root: No gtk.AccelGroup in the top level window.
** (sugar-activity:2241): DEBUG: Got client ID "10cd66701674fd91c9129518289062599600000019400000"
** (sugar-activity:2241): DEBUG: Setting initial properties
** (sugar-activity:2241): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
** (sugar-activity:2241): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
** (sugar-activity:2241): DEBUG: Received SaveComplete message in state save-yourself-done
1295182916.504526 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <hulahop.webview._Chrome instance at 0xa9a9e6c>
1295182916.510661 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <XPCOM component '<unknown>' (implementing nsIWebBrowser)>
/usr/lib/python2.6/site-packages/hulahop/webview.py:56: Warning: invalid uninstantiatable type `<invalid>' in cast to `GtkWidget'
  self.web_view.get_toplevel().destroy()
/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
  self.web_view.get_toplevel().destroy()
/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed
  self.web_view.get_toplevel().destroy()

Gdk-ERROR **: The program 'sugar-activity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 6650 error_code 150 request_code 144 minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Terminated by signal 6, pid 2241 data (None, <open file '<fdopen>', mode 'w' at 0x9786b60>, '02aecdcfa2bb8397fd09f1a2bb0df4f750ab75c8')

Another problem with Browse 115 is that in about:config the menu that appears on right mouse click does not render correctly

comment:10 Changed 8 years ago by sridhar

  • Cc sridhar added

comment:11 Changed 8 years ago by carrott

This seems to be fixed in Browse 116 on os508dx sugar 0.88.1 -- I can't reproduce a crash on The Teddy Factory website. The reproduction steps on below are out of date, you have to go to http://www.theteddyfactory.co.nz/shop/index.asp?Cat2=88 in step 1.

comment:12 Changed 7 years ago by ebordon

  • Cc ebordon added

In Browse 129 on Dextrose 3 sugar 0.94 I still having a crash when I try to logging on Ceibal's hot spot. In sugar-sweets 0.94 I have the same problem.

Message: pygobject_register_sinkfunc is deprecated (HippoCanvasBox)
Registering '@…/module-loader/python;1' (libpyloader.so)
Registering 'Python.TestComponent' (py_test_component.py)
Registering '@…/network/protocol/about;1?what=python' (pyabout.py)
returning /home/olpc/.sugar/default/org.laptop.WebActivity/data/gecko/prefs.js for key NS_APP_PREFS_50_FILE
1342725469.395581 WARNING root: KeepButton has been deprecated since Sugar 0.94 and should not be used in newly written code.
1342725469.418647 WARNING root: No gtk.AccelGroup in the top level window.
1342725469.454027 WARNING root: No gtk.AccelGroup in the top level window.
1342725469.923829 WARNING root: No gtk.AccelGroup in the top level window.
1342725469.953081 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.031296 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.058840 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.347297 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.365538 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.408373 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.411202 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.413420 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.442708 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.445776 WARNING root: No gtk.AccelGroup in the top level window.
1342725470.447958 WARNING root: No gtk.AccelGroup in the top level window.
(sugar-activity:1623): DEBUG: Got client ID "10ad6655c24555e30813427254727669900000009210000"
(sugar-activity:1623): DEBUG: Setting initial properties
(sugar-activity:1623): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:1623): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
(sugar-activity:1623): DEBUG: Received SaveComplete message in state save-yourself-done
/home/olpc/Activities/Browse.activity/webtoolbar.py:74: GtkWarning: IAgtk_entry_set_text: assertion `text != NULL' failed

self.props.text = text

1342725575.283533 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <hulahop.webview._Chrome instance at 0xae0e3cc>
1342725575.288682 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <XPCOM component '<unknown>' (implementing nsIWebBrowser)>
/usr/lib/python2.7/site-packages/hulahop/webview.py:56: Warning: invalid uninstantiatable type <invalid>' in cast to GtkWidget'

self.web_view.get_toplevel().destroy()

/usr/lib/python2.7/site-packages/hulahop/webview.py:56: GtkWarning: IAgtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

self.web_view.get_toplevel().destroy()

/usr/lib/python2.7/site-packages/hulahop/webview.py:56: GtkWarning: IAgtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

self.web_view.get_toplevel().destroy()

1342725607.249914 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <hulahop.webview._Chrome instance at 0xaddd26c>
1342725607.255197 WARNING root: Interface {c175a596-ee13-420a-aa74-13ad3a14deb1} not implemented by this instance: <XPCOM component '<unknown>' (implementing nsIWebBrowser)>
/usr/lib/python2.7/site-packages/hulahop/webview.py:56: Warning: invalid cast from (null)' to GtkWidget'

self.web_view.get_toplevel().destroy()

1342725613.634166 WARNING root: No gtk.AccelGroup in the top level window.
1342725613.674934 WARNING root: No gtk.AccelGroup in the top level window.
1342725613.811571 WARNING root: No gtk.AccelGroup in the top level window.
1342725613.814664 WARNING root: No gtk.AccelGroup in the top level window.
1342725613.816955 WARNING root: No gtk.AccelGroup in the top level window.
/usr/lib/python2.7/site-packages/hulahop/webview.py:56: Warning: invalid uninstantiatable type (null)' in cast to GtkWidget'

self.web_view.get_toplevel().destroy()


AttributeError Traceback (most recent call last)

/usr/lib/python2.7/site-packages/gtk-2.0/gobject/init.pyo in obj_set_property(self=<WebActivity object at 0xaaa325c (SugarActivity at 0xa0cf970)>, pspec=<GParamBoolean 'active'>, value=False)

99 prop = getattr(cls, name, None)

100 if prop:

--> 101 prop.setter(self, value)

102 cls.do_set_property = obj_set_property
103

/usr/lib/python2.7/site-packages/sugar/activity/activity.pyo in set_active(self=<WebActivity object at 0xaaa325c (SugarActivity at 0xa0cf970)>, active=False)

434 self._active = active
435 if not self._active and self._jobject:

--> 436 self.save()

437
438 active = gobject.property(

/usr/lib/python2.7/site-packages/sugar/activity/activity.pyo in save(self=<WebActivity object at 0xaaa325c (SugarActivity at 0xa0cf970)>)

669 self.metadatabuddies? = cjson.encode(self._get_buddies())
670

--> 671 preview = self.get_preview()

672 if preview is not None:
673 self.metadatapreview? = dbus.ByteArray(preview)

/usr/lib/python2.7/site-packages/sugar/activity/activity.pyo in get_preview(self=<WebActivity object at 0xaaa325c (SugarActivity at 0xa0cf970)>)

617 pixmap = self.canvas.get_snapshot((-1, -1, 0, 0))
618

--> 619 width, height = pixmap.get_size()

620 pixbuf = gtk.gdk.Pixbuf(gtk.gdk.COLORSPACE_RGB, 0, 8, width, height)
621 pixbuf = pixbuf.get_from_drawable(pixmap, pixmap.get_colormap(),

AttributeError: 'NoneType' object has no attribute 'get_size'

comment:13 Changed 6 years ago by godiard

  • Resolution set to obsolete
  • Status changed from assigned to closed

hulahop is not used anymore

Note: See TracTickets for help on using tickets.