Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2275 closed defect (duplicate)

Colors activity tooltips fail to repaint menu selector properly after menu items deselected

Reported by: greenfeld Owned by: manu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Colors Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description (last modified by greenfeld)

OLPC Version: 10.1.2 (XO 1.5)
Activity Version: 15

In the Colors {NOT Paint} activity, the menu items on the "Paint" menu pop up tooltips that fail to repaint the screen properly.

I have not seen other activities do this, so I do not know if it is a problem with the Paint activity itself or a component underneath it.

Reproduction:

  1. Start up the Colors {NOT Paint} Activity
  2. Click on the "Paint" menu to activate it.

3a. Highlight any of the menu icons above the menu selector which have main menu selection items below them (the palette, color selector, zoom icons, etc.) until a tooltip shows.
3b. Alternatively activate the border menu around the paint activity.

  1. Move the mouse so the tooltip disappears.

Expected Results:
The tooltip/border menu appears/disappears properly.

Actual Results:

  • For 3a, an inverse refresh of sorts appears, where the part of the main menu item's label below the tooltip gets repainted properly, but not the part of the menu label which was not overlapped.
  • For 3b, all of the main menu labels (Activity, Paint, etc.) fail to get repainted, leaving blank gray selection buttons.

Workaround: Selecting a new main menu area will cause all the menu labels to get repainted and appear onscreen.

Change History (3)

comment:1 Changed 10 years ago by sascha_silbe

  • Component changed from untriaged to Paint
  • Owner set to manu

comment:2 Changed 10 years ago by greenfeld

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Paint activity tooltips fail to repaint menu selector properly after menu items deselected to Colors activity tooltips fail to repaint menu selector properly after menu items deselected

Again this is the Colors Activity, making this a duplicate of issue #1995

comment:3 Changed 10 years ago by martin.langhoff

  • Component changed from Paint to Colors

Given that this is Colors (Colours? ;-) ) -- changing the component.

Sam -- if this is a dupe of 1995, close it as such, and maybe make a comment in #1995 about this one.

Note: See TracTickets for help on using tickets.