Opened 9 years ago

Closed 6 years ago

#2274 closed defect (obsolete)

colors activity - colors not guaranteed to be kept on journal resume

Reported by: greenfeld Owned by: manu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Colors Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description (last modified by greenfeld)

OLPC Release: 10.1.2 (XO 1.5 laptop)
Activity version: 15

This may be related to issue #2053, but I am not 100% sure.

In the Colors {not Paint} activity, colors are not guaranteed to be kept if paint is exited, the results of the paint activity saved to the journal, and the activity is resumed.

Likewise, sharing a paint activity between two XOs is not guaranteed to show the same color for the same area (but only the color drawn first on each XO laptop seems to be off), which may have a similar cause to this.

Reproduction:

  1. Start paint; draw a line with the default color
  2. Change the pen color, and draw a second line
  3. Repeat and draw a third.
  4. Exit the paint activity; save your results to a journal entry.
  5. Go into the journal and reopen the saved paint activity.

Expected Results: We see the same image
Actual Results: We may or may not see the same image, or one particular color (the first used) will be off.

Change History (5)

comment:1 Changed 9 years ago by sascha_silbe

  • Summary changed from paint activity - colors guaranteed to be kept on journal resume to paint activity - colors not guaranteed to be kept on journal resume

comment:2 Changed 9 years ago by greenfeld

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from paint activity - colors not guaranteed to be kept on journal resume to colors activity - colors not guaranteed to be kept on journal resume

This is a duplicate of issue #2053, which really probably is for the Colors activity as well.

comment:3 Changed 9 years ago by martin.langhoff

  • Component changed from Paint to Colors

comment:4 Changed 9 years ago by greenfeld

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Reopened per Gonzalo Odiard (Colors Activity != Paint Activity, may have a different root cause)

comment:5 Changed 6 years ago by godiard

  • Resolution set to obsolete
  • Status changed from reopened to closed

Colors activity was broken for a long time and is not maintained anymore.

Note: See TracTickets for help on using tickets.