Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#2174 closed defect (fixed)

FTBFS: sugar.bundle.bundle.MalformedBundleException: Activity bundle /home/sascha.silbe/sugar-jhbuild/source/pippy must specify either class or exec

Reported by: sascha_silbe Owned by: lfaraone
Priority: Unspecified by Maintainer Milestone:
Component: Pippy Version: Git as of bugdate
Severity: Blocker Keywords:
Cc: Distribution/OS:
Bug Status: Needinfo

Description

Besides the still unfixed #2077, Pippy now fails with the following error:

*** Installing pippy *** [17/26]
python setup.py install --prefix /home/sascha.silbe/sugar-jhbuild/install
Traceback (most recent call last):
  File "setup.py", line 21, in <module>
    bundlebuilder.start()
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/activity/bundlebuilder.py", line 415, in start
    config = Config()
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/activity/bundlebuilder.py", line 80, in __init__
    self.update()
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/activity/bundlebuilder.py", line 83, in update
    self.bundle = bundle = ActivityBundle(self.source_dir)
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/bundle/activitybundle.py", line 67, in __init__
    self._parse_info(info_file)
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/bundle/activitybundle.py", line 168, in _parse_info
    self._path)
sugar.bundle.bundle.MalformedBundleException: Activity bundle /home/sascha.silbe/sugar-jhbuild/source/pippy must specify either class or exec
*** Error during phase install of pippy: ########## Error running python setup.py install --prefix /home/sascha.silbe/sugar-jhbuild/install *** [17/26]

Change History (4)

comment:1 follow-up: Changed 10 years ago by m_anish

  • Bug Status changed from New to Needinfo

Can you try building again from the latest pippy/mainline snapshot. I also used to get a deprecation warning that exec must be used instead of class, but the build never failed.

The relevant commit is here.

comment:2 Changed 10 years ago by RafaelOrtiz

have anyone tested with version 38 ?

comment:3 in reply to: ↑ 1 Changed 10 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from new to closed

Replying to m_anish:

Can you try building again from the latest pippy/mainline snapshot. I also used to get a deprecation warning that exec must be used instead of class, but the build never failed.

Yes, the commit that removed support for <code>class</code> was reverted a day later because too many activities broke.

The relevant commit is here.

Thanks! I can confirm that the latest git version of Pippy doesn't trigger the corresponding warnings.

comment:4 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.