Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#2076 closed defect (incomplete)

Error during phase checkout of logilab-common

Reported by: disco Owned by: tomeu
Priority: normal Milestone:
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Minor Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

Ubuntu 10.04 lucid lynx 2.6.32-23-generic #37-Ubuntu i686

The Sugar jhbuild update process give me a series of errors when it tries to retrieve logilab-dependencies

logilab-common0.48.1.tar.gz

alfredo@UBUNTU:~/sugar-jhbuild$ ./sugar-jhbuild update
Updating sugar-jhbuild...
Already up-to-date.
Updating upstream jhbuild...
Already up-to-date.
* Checking out logilab-common * [1/30]
wget --continue ftp://ftp.logilab.fr/pub/common/logilab-common-0.48.1.tar.gz -O /home/alfredo/sugar-jhbuild/source/logilab-common-0.48.1.tar.gz
--2010-07-03 14:51:12-- ftp://ftp.logilab.fr/pub/common/logilab-common-0.48.1.tar.gz

=> "/home/alfredo/sugar-jhbuild/source/logilab-common-0.48.1.tar.gz"

Risoluzione di ftp.logilab.fr... 88.191.102.235
Connessione a ftp.logilab.fr|88.191.102.235|:21... connesso. (connected)
Accesso come utente anonymous ... Login eseguito! (done!)
==> SYST ... fatto. (done) ==> PWD ... fatto.
==> TYPE I ... fatto.(done) ==> CWD (1) /pub/common ...
La directory "pub/common" non esiste. (Directory "pub/common doesn't exist")

* Error during phase checkout of logilab-common * [1/30]
Traceback (most recent call last):

File "./sugar-jhbuild", line 62, in <module>

sys.exit(main.main(base_dir, sys.argv[1:]))

File "/home/alfredo/sugar-jhbuild/sjhbuild/main.py", line 111, in main

rc = jhbuild.commands.run(command, config, args, help=lambda: jhbuild.main.print_help(parser))

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 123, in run

return cmd.execute(config, args, help)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 52, in execute

return self.run(config, options, args, help)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/base.py", line 79, in run

return build.build()

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/frontends/buildscript.py", line 158, in build

altphases)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/frontends/terminal.py", line 264, in handle_error

icon = 'dialog-error', expire = 20)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/utils/notify.py", line 44, in notify

cmd.extend([summary.encode('utf-8'), body.encode('utf-8')])

AttributeError: 'NoneType' object has no attribute 'encode'

logilab-astng0.19.3.tar.gz

* Checking out logilab-astng * [2/30]
wget --continue ftp://ftp.logilab.fr/pub/astng/logilab-astng-0.19.3.tar.gz -O /home/alfredo/sugar-jhbuild/source/logilab-astng-0.19.3.tar.gz
--2010-07-03 14:56:07-- ftp://ftp.logilab.fr/pub/astng/logilab-astng-0.19.3.tar.gz

=> "/home/alfredo/sugar-jhbuild/source/logilab-astng-0.19.3.tar.gz"

Risoluzione di ftp.logilab.fr... 88.191.102.235
Connessione a ftp.logilab.fr|88.191.102.235|:21... connesso.(connected)
Accesso come utente anonymous ... Login eseguito!(done!)
==> SYST ... fatto.(done) ==> PWD ... fatto.(done)
==> TYPE I ... fatto.(done) ==> CWD (1) /pub/astng ...
La directory "pub/astng" non esiste.(Directory "pub/astng" doesn't exist)

* Error during phase checkout of logilab-astng * [2/30]
Traceback (most recent call last):

File "./sugar-jhbuild", line 62, in <module>

sys.exit(main.main(base_dir, sys.argv[1:]))

File "/home/alfredo/sugar-jhbuild/sjhbuild/main.py", line 111, in main

rc = jhbuild.commands.run(command, config, args, help=lambda: jhbuild.main.print_help(parser))

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 123, in run

return cmd.execute(config, args, help)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 52, in execute

return self.run(config, options, args, help)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/base.py", line 79, in run

return build.build()

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/frontends/buildscript.py", line 158, in build

altphases)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/frontends/terminal.py", line 264, in handle_error

icon = 'dialog-error', expire = 20)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/utils/notify.py", line 44, in notify

cmd.extend([summary.encode('utf-8'), body.encode('utf-8')])

AttributeError: 'NoneType' object has no attribute 'encode'

pylint-0.19.0.tar.gz

* Checking out pylint * [3/30]
wget --continue ftp://ftp.logilab.fr/pub/pylint/pylint-0.19.0.tar.gz -O /home/alfredo/sugar-jhbuild/source/pylint-0.19.0.tar.gz
--2010-07-03 14:57:26-- ftp://ftp.logilab.fr/pub/pylint/pylint-0.19.0.tar.gz

=> "/home/alfredo/sugar-jhbuild/source/pylint-0.19.0.tar.gz"

Risoluzione di ftp.logilab.fr... 88.191.102.235
Connessione a ftp.logilab.fr|88.191.102.235|:21... connesso.(connected)
Accesso come utente anonymous ... Login eseguito!(done!)
==> SYST ... fatto.(done) ==> PWD ... fatto.(done)
==> TYPE I ... fatto.(done) ==> CWD (1) /pub/pylint ...
La directory "pub/pylint" non esiste.(Directory "pub/pylint" doesn't exist)

* Error during phase checkout of pylint * [3/30]
Traceback (most recent call last):

File "./sugar-jhbuild", line 62, in <module>

sys.exit(main.main(base_dir, sys.argv[1:]))

File "/home/alfredo/sugar-jhbuild/sjhbuild/main.py", line 111, in main

rc = jhbuild.commands.run(command, config, args, help=lambda: jhbuild.main.print_help(parser))

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 123, in run

return cmd.execute(config, args, help)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 52, in execute

return self.run(config, options, args, help)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/commands/base.py", line 79, in run

return build.build()

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/frontends/buildscript.py", line 158, in build

altphases)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/frontends/terminal.py", line 264, in handle_error

icon = 'dialog-error', expire = 20)

File "/home/alfredo/sugar-jhbuild/jhbuild/jhbuild/utils/notify.py", line 44, in notify

cmd.extend([summary.encode('utf-8'), body.encode('utf-8')])

AttributeError: 'NoneType' object has no attribute 'encode'

Solved This by downloaded all 3 packages with firefox from http://ftp.logilab.org/pub/ and then put them in source directory

Change History (2)

comment:1 Changed 11 years ago by sascha_silbe

  • Component changed from sugar to sugar-jhbuild
  • Milestone changed from 0.84 to not applicable
  • Resolution set to incomplete
  • Severity changed from Trivial to Minor
  • Status changed from new to closed
  • Version changed from Unspecified to Git as of bugdate

Ubuntu 10.04 is not supported by sugar-jhbuild because it doesn't ship an essential package (python-xpcom) and contains serious bugs in some others.
If you post error messages, please do so in english by setting LC_ALL=C prior to invoking sugar-jhbuild.
Please file sugar-jhbuild problems against the sugar-jhbuild component, not sugar.

I have not been able to reproduce your problem - logilab-common and logilab-astng download fine for me and even if I force the download to fail by configuring an invalid proxy sugar-jhbuild displays an error message and the usual menu instead of breaking.

If you still get the above traceback even after updating sugar-jhbuild (and with it jhbuild), please reopen this bug with more information on how to reproduce it.

comment:2 Changed 8 years ago by dnarvaez

  • Milestone not applicable deleted

Milestone not applicable deleted

Note: See TracTickets for help on using tickets.