Opened 10 years ago

Closed 9 years ago

#1070 closed defect (fixed)

Measure 24 does not launch on F11

Reported by: walter Owned by: walter
Priority: Immediate Milestone: Unspecified
Component: Measure Version: 0.84.x
Severity: Blocker Keywords:
Cc: bernie Distribution/OS: Fedora
Bug Status: Assigned

Description

Mikus Grinbergs reported that when he tried launching measure, its "activity launch" screen pulsed for a while, then vanished. Nothing else happened. (F11 running on XO hardware).

/usr/lib/python2.6/site-packages/sugar/util.py:25: DeprecationWarning: the sha module is deprecated; use the hashlib module instead

import sha

1247624371.321454 DEBUG root: * Act 3dd3feadc7245af82d0f3814ffb398f4c56ef1e4, mesh instance None, scope private
1247624371.323714 DEBUG root: Creating a jobject.
1247624371.390232 DEBUG root: datastore.write
1247624371.444090 DEBUG root: dbus_helpers.create: 553b0836-2981-4f8a-872a-2e5e889ee93f
1247624371.446821 DEBUG root: Written object 553b0836-2981-4f8a-872a-2e5e889ee93f to the datastore.
amixer: Unable to find simple control 'PCM',0

$$journal.py: This is the file I will work on /home/soas/.sugar/default/org.laptop.MeasureActivity/data/tmpiai8Kd
Traceback (most recent call last):

File "/usr/bin/sugar-activity", line 21, in <module>

main.main()

File "/usr/lib/python2.6/site-packages/sugar/activity/main.py", line 140, in main

create_activity_instance(activity_constructor, activity_handle)

File "/usr/lib/python2.6/site-packages/sugar/activity/main.py", line 34, in create_activity_instance

activity = constructor(handle)

File "/home/soas/Activities/Measure.activity/measure.py", line 71, in init

self.audiograb = AudioGrab(self.wave.new_buffer, self.ji)

File "/home/soas/Activities/Measure.activity/audiograb.py", line 61, in init

self.PCM = self.get_PCM_gain()

File "/home/soas/Activities/Measure.activity/audiograb.py", line 382, in get_PCM_gain

return int(p)

ValueError: invalid literal for int() with base 10:
1247624372.125953 DEBUG root: _cleanup_temp_files

Attachments (3)

Measure.diff (1.3 KB) - added by DeanBrettle 9 years ago.
Patch to support envs where some mixer controls (e.g. PCM and Mic) don't exist
org.laptop.MeasureActivity-1.log (7.0 KB) - added by jasg 9 years ago.
Measure-30.xo (148.4 KB) - added by walter 9 years ago.
added missing tooltips, fixed some typos

Download all attachments as: .zip

Change History (30)

comment:1 Changed 10 years ago by arjs

  • Priority changed from Unspecified by Maintainer to Immediate
  • Severity changed from Unspecified to Blocker

code in audiograb.py is hard-linked to the names of the alsa controls in the XO alsamixer and a good first step would be to abstract that.
Help from someone to fix-code this would be great.

comment:2 Changed 10 years ago by tomeu

  • Component changed from sugar to Measure

comment:3 Changed 10 years ago by walter

  • Status changed from new to accepted

Could you please try version 27 and report back?

comment:4 Changed 10 years ago by tomeu

  • Bug Status changed from New to Needinfo

Changed 9 years ago by DeanBrettle

Patch to support envs where some mixer controls (e.g. PCM and Mic) don't exist

comment:5 Changed 9 years ago by DeanBrettle

  • Bug Status changed from Needinfo to Assigned

Version 29 fails with the same error on F12. The patch I just attached fixes it.

comment:6 Changed 9 years ago by walter

I've applied a slight variant to Dean's patch: I only catch ValueErrors with the exception handler. I'll attach v-30 for testing and if it seems to be OK, I'll post it to ALSO.

(Sorry it took me so long to get back to this... too many other distractions of late.)

comment:7 Changed 9 years ago by bernie

Measure 29 seems to work fine on F11-XO1. It fails to start in jhbuild with F12, though.

comment:8 Changed 9 years ago by walter

Hey bernie, how about some log files so I can diagnose the problem.

-walter

comment:9 Changed 9 years ago by walter

I am assuming that #1367 will address these problems as well.

comment:10 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from accepted to closed

Sorry to have taken so long to get this sorted out... I am running v30 on F11 and F13 successfully. I will be pushing F30 to ASLO and closing this ticket. Note that there are some issues being tracked in #2035.

comment:11 Changed 9 years ago by walter

  • Resolution fixed deleted
  • Status changed from closed to reopened

err. s/F30/V30

Available in git, but not yet ASLO.

comment:12 Changed 9 years ago by bernie

  • Cc bernie added

If you bundle it up, I'll test today.

comment:13 Changed 9 years ago by walter

I attached a new version of v30 t this ticket. It should launch and work on the F11 build for XO 1.5. It will launch on F11 builds for XO 1.0, but we need to test whether or not sensor mode will work. It will not launch on F9 builds, It should launch on F13 (SoaS) builds. Please attach log files for any failed launches.

comment:14 Changed 9 years ago by walter

I should have noted that this is not the final release version of Measure-30. There are some toolbar improvements queued up as well as some work to be done to ensure it launches on old systems without gst mixer support.

comment:15 follow-up: Changed 9 years ago by bernie

I tested with F11-0.88 on both XO-1 and XO-1.5.

On the XO-1.5, sound input is totally out of range and looks random. Proably a platform issue, not a bug in Measure.

What should be happening when I click Start Recording in the Sensors toolbar? On both platform, I see odd numbers on the toolbar while the mic light remains off.

comment:16 in reply to: ↑ 15 Changed 9 years ago by bernie

Replying to bernie:

What should be happening when I click Start Recording in the Sensors toolbar? On both platform, I see odd numbers on the toolbar while the mic light remains off.

Oh, wait... maybe I'm seeing the old "privacy bug" of the XO board: the mic light stays off if you bypass the high-pass filter while sampling.

comment:17 Changed 9 years ago by walter

This version has some patches to clean up various bits and it has some improved backward compatibility in the audiograb.py section. Still inconclusive sensor results on F11/OLPC 1.0 hardware.

comment:18 Changed 9 years ago by walter

The current version should work on F11 0.84/0.88 on both XO 1.0 and XO 1.5 hardware. Please test.

comment:19 Changed 9 years ago by walter

The version I just uploaded seems to work on XO 1.0 and XO 1.5 with F9 and F11. The calibration is a bit better. (Note: the humidity sensor seems to behave differently on the different hardware and the output of the light sensor is inverted between machines.) There is an occasional Pango error in displaying the sensor value that I cannot seem to properly characterize. Yet this is about usable. Please test.

comment:20 Changed 9 years ago by jasg

I tried it. The result was: the activity works for a while and after it stop suddenly. Attached the log file.

Changed 9 years ago by jasg

comment:21 Changed 9 years ago by walter

The crash seems to be related to writing the sample value to the toolbar label... Not sure of the root cause :(

comment:22 Changed 9 years ago by walter

I think that by adding gtk.thread wrappers around the value display prevents the crash reported by jasg. I also added support for 0.86+ toolbars. Please test.

comment:23 Changed 9 years ago by walter

Replaced sleep calls with gobject.timeout_add in attempt to fix problem with hanging.
Fixed? issue with gconf on F7 systems.

comment:24 Changed 9 years ago by walter

Still something wrong with the mixer or parameter settings: when cycling between sound and sensor toolbars, the levels change.

comment:25 Changed 9 years ago by carrott

Latest measure-30 has the trigger control visible on 8.2.1 on XO-1! Thank You Walter

comment:26 Changed 9 years ago by walter

Ah, but does it work? Please test it.

Changed 9 years ago by walter

added missing tooltips, fixed some typos

comment:27 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from reopened to closed

Measure 30, just released, does open on F11... closing this ticket.

Note: See TracTickets for help on using tickets.