Opened 11 years ago

Closed 10 years ago

Last modified 7 years ago

#1735 closed defect (duplicate)

Problems with Access Point names that contain non-ascii characters

Reported by: erikos Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Critical Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

1266831855.060894 DEBUG root: ----> AP name=dbus.ByteArray('k\xfcnstliche welten', variant_level=1)
Traceback (most recent call last):
  File "/home/erikos/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 1079, in _ap_props_changed_cb
    self._add_ap_to_network(ap)
  File "/home/erikos/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 1056, in _add_ap_to_network
    icon = WirelessNetworkView(ap)
  File "/home/erikos/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 115, in __init__
    self._palette = self._create_palette()
  File "/home/erikos/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 162, in _create_palette
    logging.debug("----> AP UNI name=%r", unicode(self._name, 'utf8'))
  File "/usr/lib/python2.6/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 1-6: unsupported Unicode code range

This has effects on not displaying the AP and that log can not display the shell.log anymore.

Change History (4)

comment:1 Changed 11 years ago by walter

  • Milestone changed from 0.88 to 0.90
  • Severity changed from Major to Critical

This seems critical in that it even interfere with logging. Unfortunately, it won't make 0.88.

comment:2 Changed 11 years ago by walter

  • Milestone changed from 0.90 to 0.88

Erikos ever hopeful it will make 0.88...

comment:3 Changed 10 years ago by erikos

  • Resolution set to duplicate
  • Status changed from new to closed

The issue is handled in #2023.

comment:4 Changed 7 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.