Opened 12 years ago

Closed 12 years ago

#1297 closed defect (duplicate)

Rejoining an activity does not work

Reported by: uwog Owned by: tomeu
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

  1. Start an activity
  2. Join the activity
  3. Close the activity on the initiator side
  4. Reopen the activity on the initiator side via the donut or journal to rejoin it.

=> Instead of self._shared_activity being set OR a 'joined' signal to be fired, a 'shared' signal is fired.

Note: I test this with the Write activity in jhbuild, but if you want to use that too, then you need abiword trunk, pyabiword trunk, and the attached Write patch.

Attachments (2)

Write-rejoin.diff (1.2 KB) - added by uwog 12 years ago.
Write patch to enable rejoining
sugar-toolkit-destroy.diff (773 bytes) - added by uwog 12 years ago.
For completeness: the sugar patch required by the Write patch to work

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by uwog

Write patch to enable rejoining

comment:1 Changed 12 years ago by bemasc

Duplicate of #935, I think.

See also #934.

Changed 12 years ago by uwog

For completeness: the sugar patch required by the Write patch to work

comment:2 Changed 12 years ago by uwog

  • Resolution set to duplicate
  • Status changed from new to closed

935 seems to be the same thing, except that the initial case 1 description is slightly inaccurate. See http://dev.sugarlabs.org/ticket/935#comment:3 and comment 5 on this. Comment 5 confirms this is indeed a dupe.

Note: See TracTickets for help on using tickets.