Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#1296 closed defect (fixed)

close collaboration tube after the activity window is destroyed

Reported by: tomeu Owned by: tomeu
Priority: Urgent Milestone:
Component: Sugar Version: Unspecified
Severity: Critical Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

So activities can do collaboration cleanup when the activity window is closed.

Attachments (1)

0001-Close-tube-after-the-activity-window-is-closed-1296.patch (1.1 KB) - added by tomeu 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by tomeu

This is needed so Write can migrate the session from the initiator to other participant. Please comment and tell if you see any negative consequence from this.

May be worth backporting to 0.84.

comment:2 follow-up: Changed 10 years ago by mstone

If Write is involuntarily killed, e.g. due to segfault or OOM, then this code will never be called, yes? If that happens, will the Telepathy CM still be an incorrect state as it apparently is now? (Or have I completely misunderstood the purpose of this patch?)

comment:3 in reply to: ↑ 2 Changed 10 years ago by uwog

Replying to mstone:

If Write is involuntarily killed, e.g. due to segfault or OOM, then this code will never be called, yes? If that happens, will the Telepathy CM still be an incorrect state as it apparently is now? (Or have I completely misunderstood the purpose of this patch?)

Yes, it will be just like it is now. We will make AbiCollab work with improper shutdown somewhere in the future, but for now this is a good improvement to have.

comment:4 Changed 10 years ago by tomeu

  • Milestone changed from Unspecified by Release Team to 0.86
  • Priority changed from Unspecified by Maintainer to Urgent
  • Severity changed from Unspecified to Critical

comment:5 Changed 10 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:7 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.