Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1209 closed defect (duplicate)

Language control panel needs to limit number of languages allowed, or be a scroll view

Reported by: garycmartin Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords: sayamindu
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

The Language control panel needs to limit number of languages allowed in UI, or be a scroll view. Currently you can click the (+) icon until the languages disappear off the bottom of screen, by which point the delete (-) is off-screen as well so you can no longer make ANY changes to language (without resorting to the Terminal and hacking).

A scrolling view is probably safer as that will work for different resolution displays.

Change History (12)

comment:1 Changed 12 years ago by erikos

  • Bug Status changed from Unconfirmed to Needinfo

Good catch, thanks for that ne.

comment:2 Changed 12 years ago by erikos

  • Bug Status changed from Needinfo to Assigned

comment:3 follow-up: Changed 12 years ago by erikos

  • Bug Status changed from Assigned to Needinfo

Actually, I mean I see visually the problem. But, is someone gonna select more then 3 languages maximum? I could fit 4 in by a dimension from 800x600, that sounds enough to me.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 12 years ago by garycmartin

Replying to erikos:

Actually, I mean I see visually the problem. But, is someone gonna select more then 3 languages maximum? I could fit 4 in by a dimension from 800x600, that sounds enough to me.

Sounds good enough to me also :-)

comment:5 Changed 12 years ago by erikos

  • Resolution set to wontfix
  • Status changed from new to closed

comment:6 in reply to: ↑ 4 Changed 12 years ago by garycmartin

Replying to garycmartin:

Replying to erikos:

Actually, I mean I see visually the problem. But, is someone gonna select more then 3 languages maximum? I could fit 4 in by a dimension from 800x600, that sounds enough to me.

Sounds good enough to me also :-)

So shouldn't the UI be limited to allowing 4 languages, otherwise the user can still screw up the language UI with controls going off screen?

comment:7 follow-up: Changed 12 years ago by erikos

We could. Or we add a scrolled window. AFAIK, it is not shown as long as it is not needed.

comment:8 Changed 12 years ago by erikos

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:9 in reply to: ↑ 7 Changed 12 years ago by garycmartin

Replying to erikos:

We could. Or we add a scrolled window. AFAIK, it is not shown as long as it is not needed.

What ever is easiest :-)

comment:10 Changed 12 years ago by garycmartin

  • Bug Status changed from Needinfo to New

comment:11 Changed 12 years ago by alsroot

  • Resolution set to duplicate
  • Status changed from reopened to closed

I posted patch to #308, so it looks like a dup

comment:12 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.