Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1176 closed defect (fixed)

Upgrade activities that were installed from bundles

Reported by: alsroot Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.84.x
Severity: Unspecified Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

This patch intended only for 0.84

Attachments (1)

sugar-1176.patch (1.5 KB) - added by alsroot 12 years ago.

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by alsroot

comment:1 Changed 12 years ago by alsroot

  • Cc r? removed
  • Keywords r? added

comment:2 follow-up: Changed 12 years ago by sascha_silbe

Looks like a dupe of #1042.

comment:3 in reply to: ↑ 2 Changed 12 years ago by alsroot

Replying to sascha_silbe:

Looks like a dupe of #1042.

yup, thats why thats patch only for 0.84, in 0.86 it could be fixed in other way

comment:4 Changed 12 years ago by tomeu

  • Keywords r! added; r? removed

How does this patch helps it? AFAICS the problem is that we are raising AlreadyInstalledException when updating, cannot see what has to do where the existing bundle was installed.

comment:5 follow-up: Changed 12 years ago by alsroot

in existed 0.84 code AlreadyInstalledException will be raised in any case(if we have the same bundle_id despite of the current version)

attached patch do that only for preinstalled(not in ~/Activities) activities, for .xo activities it just pass though and compare versions to raise AlreadyInstalledException

comment:6 Changed 12 years ago by alsroot

  • Milestone changed from Unspecified by Release Team to 0.84

comment:7 in reply to: ↑ 5 Changed 12 years ago by tomeu

  • Keywords r+ added; r! removed
  • Resolution set to fixed
  • Status changed from new to closed

Replying to alsroot:

in existed 0.84 code AlreadyInstalledException will be raised in any case(if we have the same bundle_id despite of the current version)

attached patch do that only for preinstalled(not in ~/Activities) activities, for .xo activities it just pass though and compare versions to raise AlreadyInstalledException

ok, got it now, thanks. Wish the naming of those funcs was clearer, but as this is only for 0.84...

comment:8 Changed 8 years ago by godiard

  • Milestone 0.84 deleted

Milestone 0.84 deleted

Note: See TracTickets for help on using tickets.