Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#1175 closed defect (fixed)

Do not fail while displaying activity icon for bundles in Journal

Reported by: alsroot Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Unspecified Keywords: r+
Cc: sascha_silbe Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Shell temporally unzip icon from bundles and creates auto_ptr object
that object assigned to gtk.Image.props.file that loses auto_ptr instance. As result sugar-0.84 can't display icon of activity palette in Journal.

Attached patch looks like dirty hack but it could affectively handle that problem and could be applied only to 0.84 branch(since shell from git process icons differently in Journal and doesn't fail)

Attachments (1)

sugar-1175.patch (1.2 KB) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by alsroot

  • Component changed from sugar to sugar-toolkit
  • Owner changed from tomeu to erikos

comment:2 Changed 10 years ago by alsroot

  • Keywords r? added

comment:3 Changed 10 years ago by sascha_silbe

  • Cc sascha_silbe added

Changed 10 years ago by alsroot

comment:4 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

Pushed, thanks!

comment:5 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar
Note: See TracTickets for help on using tickets.