Opened 4 years ago

Closed 3 years ago

Last modified 14 months ago

#2483 closed defect (fixed)

Neighborhood view is sometimes greyed out or owner buddy is missing

Reported by: satellit Owned by: mchua pbrobinson sdz
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.90.x
Severity: Major Keywords: 11.2.0 r? dx3
Cc: pbrobinson, alsroot, rgs, erikos Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

Fedora-14-RC1-i686-SB-Live-SoaS.iso Booted as a CD loses the Central Avitar in the F1 Network Neighborhood (Telepathy-gabble) and then the whole field greys out after running a period of time (5-6 minutes?)

Possibly Related to:?
http://bugs.sugarlabs.org/ticket/2355
http://bugs.sugarlabs.org/ticket/2395
https://bugzilla.redhat.com/show_bug.cgi?id=647414

Attachments (2)

0001-Do-not-remove-bodies-on-offline-status-2483.patch (4.7 KB) - added by alsroot 4 years ago.
0001-Do-not-remove-bodies-on-offline-status-2483.2.patch (3.9 KB) - added by pbrobinson 3 years ago.
Updated patch to apply against 0.92.1

Download all attachments as: .zip

Change History (19)

comment:1 Changed 4 years ago by satellit

  • Cc pbrobinson added
  • Component changed from untriaged to SoaS
  • Owner set to mchua pbrobinson sdz

comment:2 Changed 4 years ago by alsroot

  • Cc alsroot added
  • Keywords r? added

Attached patch fixes at least XO disappearing on F1 view.

comment:3 Changed 4 years ago by alsroot

"grey" issue might relate to unhandled exceptions (got the same grey F1 on one of exceptions during debugging). After applying patch didn't reproduce it for 10h. Though got duplicates for several bodies (online users on jabber.sl.o is less then bodies on F1), that might relate to the patch.

comment:4 Changed 4 years ago by alsroot

Use case with doubled bodies in F1 view was described in #2534

comment:5 Changed 4 years ago by rgs

  • Cc rgs added

comment:6 Changed 4 years ago by rgs

Patch works for me. Nice work!

comment:7 follow-up: Changed 3 years ago by bernie

Nobody reviewed this patch for 5 months? :-(

comment:8 in reply to: ↑ 7 Changed 3 years ago by pbrobinson

Replying to bernie:

Nobody reviewed this patch for 5 months? :-(

Wrong component? Not send to devel for review like other patches?

comment:9 Changed 3 years ago by erikos

  • Summary changed from Booted Fedora-14-RC1-i686-Live-SoaS CD loses display of f1 network neighborhood after about 6 minutes to Neighborhood view is sometimes greyed out or owner buddy is missing

comment:10 Changed 3 years ago by erikos

  • Component changed from Sugar on a Stick (SoaS) to sugar
  • Keywords 11.2.0 added; Telepathy-gabble Sugar removed
  • Milestone changed from Unspecified by Release Team to 0.92

#2805 and #2806 closed as dupes, http://dev.laptop.org/ticket/10671 has some more info as well.

comment:11 Changed 3 years ago by m_anish

  • Keywords dx3 added

comment:12 Changed 3 years ago by pbrobinson

Patch also doesn't apply clearly to current head or 0.92.x. Can someone please update it and submit it to sugar-devel for review.

Changed 3 years ago by pbrobinson

Updated patch to apply against 0.92.1

comment:13 Changed 3 years ago by pbrobinson

This patch needs more work. It duplicates the avatar on the network screen and changes its colour, its been referred to as "Disco mode"

comment:14 Changed 3 years ago by satellit

sugar-log Trisquel 4.5.1-sugar (0.88.1) -from shell log

"Ceibal" buddy icons jumping around on f1 neighborhood view and changing names/colors
0n 0.88.1 (this record) the buddy icons flash on and off changing positions/colors and sometimes names but do not fill up f1 screen.
on 0.92.1 all old avitars (buddys) are retained and fill up the f1 screen eventually

-------------sugar.log / shell.log-------------

1306180534.813456 ERROR root: Traceback (most recent call last):

File "/opt/sweets/sugar/src/jarabe/view/buddyicon.py", line 39, in _buddy_presence_change_cb

self._update_color()

File "/opt/sweets/sugar/src/jarabe/view/buddyicon.py", line 45, in _update_color

palette_icon = palette.props.icon

AttributeError: 'NoneType' object has no attribute 'props'

1306180604.017894 ERROR root: Traceback (most recent call last):

File "/opt/sweets/sugar/src/jarabe/view/buddyicon.py", line 39, in _buddy_presence_change_cb

self._update_color()

File "/opt/sweets/sugar/src/jarabe/view/buddyicon.py", line 45, in _update_color

palette_icon = palette.props.icon

AttributeError: 'NoneType' object has no attribute 'props'

1306180640.043161 ERROR root: Traceback (most recent call last):

File "/opt/sweets/sugar/src/jarabe/view/buddyicon.py", line 39, in _buddy_presence_change_cb

self._update_color()

File "/opt/sweets/sugar/src/jarabe/view/buddyicon.py", line 45, in _update_color

palette_icon = palette.props.icon

AttributeError: 'NoneType' object has no attribute 'props'

comment:15 Changed 3 years ago by satellit

  • Cc erikos added

http://bugs.sugarlabs.org/ticket/2845 is related? via patch mentioned here.
See the screen shot attached there.
in 0.92.1 sugar in latest nightly compose I am seeing avitars from testing I did 4 days ago and have since closed down. Many of the avitars have names of form :xxxxxxxx@jabber....
At the moment any live CD of f15-16 fills up with about 120+ avitars. While the 0.88.1 sugar and jabber show the number as much smaller (about 20)
The patch may no longer be needed as alsroot fixed the cause of the problem "some people use the same jids from several IPs at the same time, thus all some one was kicking his alter ego"

comment:16 Changed 3 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

http://dev.laptop.org/ticket/10671 has been fixed, please reopen if you see it occur again.

comment:17 Changed 14 months ago by dnarvaez

  • Milestone 0.92 deleted

Milestone 0.92 deleted

Note: See TracTickets for help on using tickets.