Opened 4 years ago

Last modified 4 months ago

#2355 reopened defect

Neighborhood shows Jabber account id (hex_number@server.domain) instead of nick name

Reported by: satellit Owned by: tomeu
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.90.x
Severity: Major Keywords: telepathy-gabble, neighborhood, bad names
Cc: tomeu, erikos, alsroot, JerryV, sascha_silbe Distribution/OS:
Bug Status: Unconfirmed

Description

wrong names of format xxxxxxxxxx@jabber,sugarlabs.org in latest telepathy-gabble neighborhood view

0.89-9-1.fc14.noarch

related to:
http://bugs.sugarlabs.org/ticket/2335#comment:6

Attachments (3)

log-1338767855.zip (81.5 KB) - added by JerryV 2 years ago.
captured logs of the registeration process
accounts.cfg.zip (1.5 KB) - added by JerryV 2 years ago.
accounts.cfg files.
Sugar_Names.png (147.6 KB) - added by ignacio 4 months ago.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 4 years ago by tomeu

  • Component changed from untriaged to sugar

comment:2 Changed 4 years ago by bernie

  • Severity changed from Unspecified to Blocker

Also happens on F14 with jhbuild or latest distro packages.

comment:3 Changed 4 years ago by satellit

also on latest F14 Beta RC3 HD netinstall of sugar-desktop to HD

comment:4 Changed 4 years ago by satellit

Also throwing mutiples of same name with no color (7 instances "Anurag Chowdhury")
f14 Beta RC3 HD Netinstall "GOLD"

comment:5 Changed 4 years ago by satellit

also will not join chat activity (due to garbled names?)

comment:6 Changed 4 years ago by satellit

soas-i386-20100925.18.iso

wrong names of format xxxxxxxxxx@jabber,sugarlabs.org seen here:

also see sending instances Avitar's name in F1 neighborhood with correct name (2nd Copy) not at center of neighborhood.
Note Seen on anther instance of sugar (openSUSE-sugar-Virtualbox install sugar 0.88.0) correctly named so it is transmitting to jabber correctly

comment:7 Changed 4 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 4 years ago by satellit

  • Cc tomeu erikos added
  • Milestone changed from Unspecified by Release Team to 0.90
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from wrong names of format xxxxxxxxxx@jabber,sugarlabs.org in latest telepathy-gabble neighborhood view to wrong names of format xxxxxxxxxx@jabber,sugarlabs.org in latest telepathy-gabble neighborhood view-still present in F14 Updates testing

f14-Beta-Live CD installed to HD 09/29/2010 2Pm PST
Avitars present on gdm log in to sugar. 90% of garbled form xxxxxxxxx@…
Note My avitar color and name shown 2 times. in center and offset in field with correct name

cp: change color of avitar with new color switcher in About Me
restart
No avitars ever reappear.
It takes complete shutdown and restart to get avitars back
repeat cycle: my central avitar disappears after about 3 minutes?

Does presence service shut down after a fixed time with no traffic? Saw discussion in #telepathy about this today

Note
Update to Presence service to Fix this is not yet in updates-testing F14

LOG of install:

# yum groupinstall sugar-desktop
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
fedora/metalink | 6.8 kB 00:00
fedora | 4.3 kB 00:00
fedora/primary_db | 11 MB 00:12
updates-testing/metalink | 4.0 kB 00:00
updates-testing | 4.7 kB 00:00
updates-testing/primary_db | 2.5 MB 00:03
Setting up Group Process
fedora/group_gz | 406 kB 00:00
updates-testing/group_gz

| 406 kB 00:01

clip------(part of install dialog)----------

sugar-artwork i686 0.89.4-1.fc14 fedora 153 k
sugar-base i686 0.90.0-1.fc14 fedora 60 k
sugar-datastore i686 0.89.4-1.fc14 fedora 54 k
sugar-presence-service noarch 0.90.1-1.fc14 fedora 102 k
sugar-settings-manager i686 0.87.2-1.fc13 fedora 11 k
sugar-toolkit i686 0.89.5-1.fc14 fedora 327 k

clip --------

comment:9 Changed 4 years ago by satellit

  • Bug Status changed from Unconfirmed to Needinfo
  • Resolution set to fixed
  • Status changed from reopened to closed

after several shutdowns and restarts it is working correctly???

I guess it is resolved? Not sure why it takes 3-4 cold reboots to get it to work.

comment:10 Changed 4 years ago by satellit

  • Resolution fixed deleted
  • Status changed from closed to reopened

still present in soas-i386-20101012.15.iso liveinst from running CD
use of color selector in CP/about me and restart returns you to gdm login; This fixes the xxxxx@jabber names first displayed in f1 Neighborhood.

comment:11 Changed 4 years ago by satellit

Log File from latest soas-v4-Remix.iso built today using updates-testing repo

1287165481.880592 WARNING s-p-s.presenceservice: Error fetching buddy properties for handle 15 xmpp/bine_40jabber_2esugarlabs_2eorg: org.freedesktop.Telepathy.Error.NetworkError: Failed to query the PEP node: the addressed JID or item requested cannot be found

1287165482.070292 WARNING s-p-s.presenceservice: Error fetching activities for handle 15 xmpp/bine_40jabber_2esugarlabs_2eorg: org.freedesktop.Telepathy.Error.NetworkError: Error in pubsub reply: server error

this is fixed by changing colors in CP and restarting sugar then names are correct

comment:12 Changed 4 years ago by satellit

note: the Users Central Avitar XO disappears here on F1 Neighborhood after 5-10 minutes of running? Some sort of time out? Other user's Avitars remain

comment:13 Changed 4 years ago by satellit

also in soas-i386-20101014.17.iso if you hit "register" on f3 dropdown, after 8 min delay get Registration failed. Then F1 neighborhood has correct naming.
Seems to be related to not getting full reponse from jabber on initial display of names

comment:14 Changed 4 years ago by satellit

  • Component changed from sugar to SoaS

soas-i386-20101016.18.iso

still loses f1 Central Avitar after about passage of time

also see http://bugs.sugarlabs.org/ticket/2395

comment:15 Changed 4 years ago by wronkiew

I saw this bug while testing soas-i386-20101025.05.iso as a live CD on a MacBook Pro.

comment:16 Changed 4 years ago by satellit

  • Milestone changed from 0.90 to Mango Lassi

comment:17 Changed 4 years ago by satellit

see:https://bugzilla.redhat.com/show_bug.cgi?id=649013

comment:18 Changed 3 years ago by alsroot

  • Cc alsroot added

My own investigation on new jabber.sl.o, with Prosody instead of ejabberd and experimental colab fixes from http://lists.sugarlabs.org/archive/sugar-devel/2011-July/032295.html, showed that there two kinds of issues:

# some of buddies on jabber.sl.o didn't publish vcard info on jabber server, thus no way to get nick name; sounds more like a client side bug but it is not reproducible with sugar patches from mentioned sugar-devel post
# right after buddy registration, upstream sugar didn't take into account nick name; for now it is fixed on server side (on jabber.sl.o) but might be better to have client side driven code

comment:19 follow-up: Changed 3 years ago by JerryV

  • Cc JerryV added

Observed same problem using 11.3-os3, fix was to delete ~/.mission=control/accounts/accounts.cfg and restart sugar, then the NICK was displayed on j.s.o or on a local schoolserver correctly.

comment:20 in reply to: ↑ 19 Changed 3 years ago by alsroot

Replying to JerryV:

Observed same problem using 11.3-os3, fix was to delete ~/.mission=control/accounts/accounts.cfg and restart sugar, then the NICK was displayed on j.s.o or on a local schoolserver correctly.

Did you start 11.3-os3 on the existed ~/.sugar env, ie, it was created by older sugar? Do you have ~/.sugar/default/accounts/accounts.cfg right now? Did you manage to reproduce the issue once more after removing ~/.mission=control/accounts/accounts.cfg?

comment:21 Changed 3 years ago by JerryV

Think the issue is when you connect up to an olpc-xs first then start switching things around. Can't reproduce this atm, I'll be back with further info.

comment:22 Changed 2 years ago by sascha_silbe

#3071 may have some additional information.

comment:23 Changed 2 years ago by sascha_silbe

  • Bug Status changed from Needinfo to New
  • Cc sascha_silbe added
  • Component changed from Sugar on a Stick (SoaS) to sugar
  • Distribution/OS Fedora deleted
  • Milestone Mango Lassi deleted
  • Severity changed from Blocker to Major
  • Summary changed from wrong names of format xxxxxxxxxx@jabber,sugarlabs.org in latest telepathy-gabble neighborhood view-still present in F14 Updates testing to Neighborhood shows Jabber account id (hex_number@server.domain) instead of nick name

Downstream ticket OLPC#10750 has some more information as well.

David Leeming reported seeing this on OLPC OS 11.3.0 (Sugar 0.94.1 based) in combination with XS 0.6, so it's independent of the Jabber server used.

As I've been seeing it on Debian based systems, it's also distro independent.

comment:24 Changed 2 years ago by alsroot

It can't be distro or server specific. The current status on jabber.sugarlabs.org. There are some accounts (seems to be Sugar Shell created, i.e., with "/sugar" resource) that never [re]published proper nickname via pubsub, i.e., published bare jids as nicks.

The way to check this issue on client side is looking into accounts.cfg file create by telepathy-mission-control, if it contains bare jids for "param-nickname"/"Nickname"/"NormalizedName" keys, thus, jabber server will never know nicknames.

While working on announced telepathy rework in Sweets Distribution repos, I faced this issue and the way I suppressed it (it seems to be) is passing "nick" while creating account on telepathy-mission-control. http://git.sugarlabs.org/desktop/sugar/blobs/master/src/jarabe/plugins/telepathy/neighborhood.py#line186

comment:25 Changed 2 years ago by JerryV

Ok, I have a XS-0.7 running in my testing network, after registering with the XS neighbourhood was showing the short nicks. After shutting the XOs down for 24 hours, now neighbourhood is showing the long jid in place of nicks. I think mission-control is messing with the accounts.cfg file at some point after registering to the schoolserver. I'm going to start with os885 with full sugar debugging enable on a machine that was never registered to see if I can catch just when this occurs.

Changed 2 years ago by JerryV

captured logs of the registeration process

Changed 2 years ago by JerryV

accounts.cfg files.

comment:27 Changed 13 months ago by dnarvaez

  • Milestone set to Unspecified

comment:28 Changed 13 months ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:29 Changed 4 months ago by ignacio

  • Priority changed from Unspecified by Maintainer to Normal

Changed 4 months ago by ignacio

Note: See TracTickets for help on using tickets.