Opened 3 years ago

Closed 3 years ago

Last modified 13 months ago

#2845 closed defect (notabug)

F15 RC2 F! View of Jabber fills up with duplicate avatars that constantly change colors en-mass

Reported by: satellit Owned by: mchua pbrobinson sdz
Priority: Unspecified by Maintainer Milestone:
Component: Sugar on a Stick (SoaS) Version: 0.92.x
Severity: Major Keywords: telepathy-mission-control
Cc: pbrobinson, alsroot, erikos Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

F15 Jabber fills up with duplicate avitars that constantly change colors en-mass.
In latest updated HD install of @sugar-desktop in DVD F15 RC2 there is a rogue avitar that duplicates itself until it fills up the f1 neighborhood view. All instances change colors en-mass and have the same name. (Cebal)

Attachments (1)

0_92_1.JPG (674.9 KB) - added by satellit 3 years ago.
sugar 0.92.1 in fedora15: No avitars seem to be removed when the user exits

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by satellit

  • Component changed from untriaged to telepathy
  • Keywords telepathy-mission-control added; Telepathy jabber removed
  • Owner set to gdesmott

telepathy-mission-control-5.7.10-1.fc15.i686
Updated to
https://admin.fedoraproject.org/updates/telepathy-mission-control-5.7.11-1.fc15
still present after update

comment:2 Changed 3 years ago by satellit

  • Component changed from telepathy to Sugar on a Stick (SoaS)
  • Distribution/OS changed from Fedora to Unspecified
  • Owner changed from gdesmott to mchua pbrobinson sdz

comment:3 Changed 3 years ago by satellit

  • Cc pbrobinson added

alsroot fixed this:
<alsroot> satellit_: I've found what was the problem w/ blinking buddies, some people use the same jids from several IPs at the same time, thus all some one was kicking his alter ego
.....
<alsroot> satellit_: I've just changed jabber.sl.o config, so it kicks new buddies
<satellit_> ok All new buddies or just ones with same jids on different IP's?
<alsroot> satellit_: nope, exactly jids duplicates

comment:4 Changed 3 years ago by satellit

  • Cc alsroot added

nice feature to add:
A button on frame of f1 view to refresh jabber screen.

Changed 3 years ago by satellit

sugar 0.92.1 in fedora15: No avitars seem to be removed when the user exits

comment:5 Changed 3 years ago by satellit

  • Cc erikos added
  • Distribution/OS changed from Unspecified to Fedora

there is a problem where in sugar 0.92.1, avitars are added to f1 neighborhood but never removed when the users exit. This build up has occurred over several days now since alsroot fixed the "disco" behavior caused by collisions "I've found what was the problem w/ blinking buddies, some people use the same jids from several IPs at the same time, thus all some one was kicking his alter ego"
"I've just changed jabber.sl.o config, so it kicks new buddies", see note above.
This does not occur in sugar 0.88.1 (Trisquel 4.5.1-sugar where the number of avitars visible match the jabber's lists. (confirmed per IRC communication with alsroot)
I believe that this behavior of sugar 0.92.1 was masked by the behavior mentioned above.

comment:6 Changed 3 years ago by pbrobinson

  • Resolution set to notabug
  • Status changed from new to closed
  • Summary changed from F15 RC2 F! View of Jabber fills up with duplicate avitars that constantly change colors en-mass to F15 RC2 F! View of Jabber fills up with duplicate avatars that constantly change colors en-mass

This isn't a bug in 0.92.1 its a problem with the patch provided in SL bug 2483. I applied the patch to see if it fixed the the problem in that bug but it causes the dupe avatars so the patch has since been dropped so this isn't a bug.

We can't really go around changing all jabber servers, in some cases this might not even be possible.

comment:7 Changed 13 months ago by dnarvaez

  • Milestone 0.92 deleted

Milestone 0.92 deleted

Note: See TracTickets for help on using tickets.