Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#89 closed defect (fixed)

Journal Focus search is broken

Reported by: garycmartin Owned by: marcopg
Priority: major Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Keywords:
Cc: tomeu Distribution/OS:
Bug Status:

Description

Joyride 2573, XO hardware.

The Journal works fine from everywhere else I've tried (frame icon, home icon below XO, activity zoom key from some other zoom view), but if you touch the Journal search key on an XO (even if you're already looking at the Journal) Sugar locks-up and you have to reboot.

Attachments (1)

89.patch (2.7 KB) - added by erikos 12 years ago.
make the focus search a method in the journalactivity instead of a dbus one

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by erikos

Gary, thanks for the report.

The dbus call self.focus_journal_search is blocked. Similar to the issues with the blocked networking dbus calls on the XO.

comment:2 Changed 12 years ago by erikos

  • Cc tomeu added
  • Milestone set to 0.84
  • Summary changed from Pressing the XO key for Journal search (spyglass) locks up Sugar requiring a reboot to Journal Focus serach is broken
  • Version set to Git as of bugdate

This is not XO specific, it is a regression from moving the journal into the shell. Since the journal is part of the shell, this does not need to be a dbus call anymore (and activities will not need this functionality, they can use ShowObject and ChooseObject).

comment:3 Changed 12 years ago by erikos

  • Summary changed from Journal Focus serach is broken to Journal Focus search is broken

Changed 12 years ago by erikos

make the focus search a method in the journalactivity instead of a dbus one

comment:4 Changed 12 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

pushed to git sugar after reviewing by tomeu

comment:5 Changed 8 years ago by godiard

  • Milestone 0.84 deleted

Milestone 0.84 deleted

Note: See TracTickets for help on using tickets.