Opened 11 years ago

Closed 10 years ago

Last modified 6 years ago

#815 closed enhancement (fixed)

Browse right click pallet missing icon for 'Download ...' and incorrectly named

Reported by: garycmartin Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: 0.84.x
Severity: Major Keywords:
Cc: Eben, HoboPrimate Distribution/OS: Unspecified
Bug Status: Assigned

Description

The right click palette for interacting with page content is missing its icon for "Download ...." (download link, download image etc). I'd like to suggest that this menu item is incorrectly named. It should be something like "Keep", "Keep ....", or "Keep .... in Journal", and should use the standard keep icon.

Attachments (4)

missing icon for browse download palette.png (20.2 KB) - added by garycmartin 11 years ago.
link.png (94.8 KB) - added by erikos 10 years ago.
Options for links
image.png (173.3 KB) - added by erikos 10 years ago.
Image options
image_palette.png (39.6 KB) - added by erikos 10 years ago.
image palette: Keep image [image name]

Download all attachments as: .zip

Change History (22)

Changed 11 years ago by garycmartin

comment:1 Changed 11 years ago by tomeu

  • Cc Eben HoboPrimate added

Thanks Gary. Eben, Eduardo, any opinions?

comment:2 Changed 11 years ago by HoboPrimate

I have no idea about this one, but the submitter is right, in that where these laptops go, download (or upload) will not mean much to kids.

comment:3 Changed 11 years ago by HoboPrimate

Still, "download" is pretty much splattered everywhere on the web, so using a different word like "Keep", might clash with that culture, where webpages use "Download" or "Get" when offering their stuff to the user.

comment:4 Changed 11 years ago by garycmartin

We have a bunch of stuff on the 0.86 roadmap for Browse, can we make a call on this and roll it into the work? I guess we all agree an icon is needed, with the decision being should we standardise and use Keep as we do in the rest of the UI when objects are to be added to the Journal.

comment:5 Changed 11 years ago by HoboPrimate

I agree then that "Keep" and its icon be used here and elsewhere something is added to the Journal, no matter if it's a local or network transfer.

comment:6 follow-up: Changed 11 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Milestone changed from Unspecified by Release Team to 0.86
  • Version changed from Unspecified to 0.84.x

Some thoughts here:

a) The alert does talk as well about: "Downloading image..." If we go down that road and use "keep"- we have change that as well. We might

b) What would be the icon - I guess the keep icon we use as well in the clipboard for example ?

c) The naming of Copy -> maybe it would be more meaningful to call this: "copy to clipboard" as we do in other places already?

comment:7 Changed 11 years ago by erikos

  • Severity changed from Minor to Major

comment:8 Changed 11 years ago by HoboPrimate

a) you could say "Transfering blabla" or "Keeping blablabla"
b) If "keep" is used, then the keep icon seems best
c) I would vote for "copy link", because otherwise the user may think he is copying the object itself (linked file) and not the pointer to it (link) (I myself was a bit confused at first to what was going to be copied)

I would like to know what is Eben's idea about using the keep terminology here.

comment:9 Changed 10 years ago by erikos

  • Type changed from defect to enhancement

I would really like to get this one in before the feature freeze. Can we decide on a good naming for the palettes?

comment:10 in reply to: ↑ 6 Changed 10 years ago by garycmartin

Replying to erikos:

Some thoughts here:

a) The alert does talk as well about: "Downloading image..." If we go down that road and use "keep"- we have change that as well. We might

I'm fine with the current alert text. You request keeping some object, the browser has to download that object.

b) What would be the icon - I guess the keep icon we use as well in the clipboard for example ?

Yes, the coloured "Keep" icon just like the Clipboard palette uses, with the text as "Keep <object>"

c) The naming of Copy -> maybe it would be more meaningful to call this: "copy to clipboard" as we do in other places already?

Hmm, just checked, the Journal just uses the word "Copy", perhaps the Journal string there should also change to "Copy to clipboard" to be more specific?

Changed 10 years ago by erikos

Options for links

Changed 10 years ago by erikos

Image options

comment:11 Changed 10 years ago by erikos

I have know added the code, based on this feedback. Does that look good like that?

comment:12 follow-up: Changed 10 years ago by erikos

Gary, sorry - did not see your comment. The question is now: if we use 'Keep image' or 'Keep [image name]'? There are some non-descriptive image names like blah12uy67.jpg or similar.

comment:13 in reply to: ↑ 12 Changed 10 years ago by garycmartin

Replying to erikos:

Gary, sorry - did not see your comment. The question is now: if we use 'Keep image' or 'Keep [image name]'? There are some non-descriptive image names like blah12uy67.jpg or similar.

'Keep image' would be a fine improvement for me, I guess 'Keep [image name]' would be a bonus feature ;-) There's not much we can do about non-descriptive image names, and that name is what is going to end up in the Journal anyway when you go looking for it later.

comment:14 follow-up: Changed 10 years ago by sascha_silbe

How about 'Keep image <image name>' then? Makes it perfectly clear we're saving an image, not something else (e.g. the HTML page itself).

comment:15 in reply to: ↑ 14 Changed 10 years ago by garycmartin

Replying to sascha_silbe:

How about 'Keep image <image name>' then? Makes it perfectly clear we're saving an image, not something else (e.g. the HTML page itself).

Sure would be OK with that also. BTW, the latest screen shots above are a great improvement over what we had before :-)

Changed 10 years ago by erikos

image palette: Keep image [image name]

comment:16 Changed 10 years ago by erikos

The 'keep image [image name]' might be a bit redundant information as the file name is already in the palette title. I will leave it out for now and push what we have into git. If someone feels strong about it - please speak up in the next hours.

Thanks for all the good discussion so far.

comment:17 Changed 10 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:18 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.