Opened 12 years ago

Closed 11 years ago

#814 closed enhancement (fixed)

Difficult to install VirtualBox tools in soas-appliance

Reported by: wadeb Owned by: sdz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Resolved

Description

There are some big hurdles here.

First, you have to manually mount /dev/dvd to /media as the normal Fedora auto mounting is not activating for some reason.

Then, you have to install gcc, make and kernel-devel. But with the latest appliance, kernel-devel brings in a newer version of the headers than what is installed in the appliance.

So, you have to yum update kernel to get the new kernel.

Finally, you have to edit /boot/grub/grub.conf to boot the new kernel.

Is there any way we could make this easier? How far off is pre-installing the VirtualBox tools? It currently adds an hour or so each time you want to check out a new appliance snapshot, even without the above issues.

BTW, recent appliance snapshots are working great generally, great work!

Change History (1)

comment:1 Changed 11 years ago by sdz

  • Bug Status changed from Unconfirmed to Resolved
  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from defect to enhancement

I heard there was some progress here lately. Looks like this can be closed. Thanks Wade for taking on this one! :)

Note: See TracTickets for help on using tickets.