Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#70 closed defect (obsolete)

setup.py dist_xo error (meaningfull information for debugging).

Reported by: RafaelOrtiz Owned by: sascha_silbe
Priority: Normal Milestone:
Component: sugar-jhbuild Version: 0.83.x
Severity: Minor Keywords: chroot
Cc: Distribution/OS: Debian
Bug Status: Needinfo

Description

while trying to build an xo bundle i got this error


Traceback (most recent call last):


File "setup.py", line 22, in <module>


bundlebuilder.start()


File "/usr/lib/python2.5/site-packages/sugar/activity/bundlebuilder.py", line 395, in start


globals()+ args[0?](config, options, args[1:])


File "/usr/lib/python2.5/site-packages/sugar/activity/bundlebuilder.py", line 216, in cmd_dist_xo


builder.build()


File "/usr/lib/python2.5/site-packages/sugar/activity/bundlebuilder.py", line 79, in build


self.build_locale()


File "/usr/lib/python2.5/site-packages/sugar/activity/bundlebuilder.py", line 102, in build_locale


retcode = subprocess.call(args)


File "/usr/lib/python2.5/subprocess.py", line 444, in call


return Popen(*popenargs, kwargs).wait()


File "/usr/lib/python2.5/subprocess.py", line 594, in init


errread, errwrite)


File "/usr/lib/python2.5/subprocess.py", line 1153, in _execute_child


raise child_exception


OSError: [Errno 2] No such file or directory

the solution was to install gettext, but we should display a more explicit information to solve it.

Change History (13)

comment:1 Changed 12 years ago by marcopg

  • Bug Status set to New
  • Distribution/OS set to Unspecified
  • Milestone set to 0.84
  • Priority changed from major to Normal
  • Severity set to Minor
  • Version set to 0.83.x

comment:2 Changed 12 years ago by marcopg

  • Component changed from sugar to sugar-toolkit

comment:3 Changed 12 years ago by homunq

  • Keywords sugar-love added

comment:4 Changed 12 years ago by erikos

  • Milestone changed from 0.84 to 0.86

comment:5 Changed 12 years ago by erikos

  • Component changed from sugar-toolkit to sugar-jhbuild

This was encountered on sugar-jhbuild debian. Is gettext listed in the dependencies?

comment:6 Changed 12 years ago by RafaelOrtiz

yes gettext is listed on the dependencies.

sugar-jhbuild/config/sysdeps/debian-unstable.xml

i presume is a matter of the depscheck script not entirely working on debian..

comment:7 Changed 12 years ago by sascha_silbe

You mean gettext is not installed on your system, but "./sugar-jhbuild depscheck" doesn't output anything (not even a warning)?
Can you post the output of "lsb_release -a" and "git remote -v" (in the sugar-jhbuild directory), please?

comment:8 Changed 12 years ago by sascha_silbe

  • Owner changed from marcopg to sascha_silbe
  • Status changed from new to accepted

Taking away from marco.

comment:9 Changed 12 years ago by RafaelOrtiz

  • Bug Status changed from New to Unconfirmed

For now i'm not able to reproduce it, leaving unconfirmed till further notice or till someone can setup a Sugar chroot enviroment in debian.

comment:10 Changed 12 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to Needinfo
  • Distribution/OS changed from Unspecified to Debian
  • Keywords chroot added; sugar-love removed

Ah, so this is inside a chroot? It works fine on a regular install (I use sugar-jhbuild on Debian squeeze on my XO) so it's most likely something chroot-specific.
Setting to needinfo until someone can reproduce and provide the output requested above.

comment:11 Changed 12 years ago by RafaelOrtiz

Agree, this one seems to be chroot specific.
let's see if someone can reproduce it.

comment:13 Changed 12 years ago by sascha_silbe

  • Resolution set to obsolete
  • Status changed from accepted to closed

Cannot reproduce, sugar-jhbuild works fine for me inside chroot. Please reopen if you encounter this again.

comment:14 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.