Opened 12 years ago

Closed 12 years ago

#56 closed defect (invalid)

[XO-LiveCD_081112] Laptop and XO aren't showing on Neighborhood.

Reported by: overbyte Owned by: marcopg
Priority: major Milestone:
Component: Sugar Version:
Severity: Blocker Keywords: collaboration, LiveCD
Cc: overbyte@…, morgan.collett@…, sascha-web-dev.sugarlabs.org@… Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I just received my G1G1 XO. Wanting to emulate another XO, I installed Sugar LiveCD on a Toshiba. The XO and Toshiba each can see and connect to my wireless AP (and other APs in the area), and browse the Internet okay, but they don't see each other on Neighborhood view. However, after various retries, they happened to see each other once and I could invite & collaborate on activities for that short session, but can't repeat it. I notice that they will momentarily appear on Neighborhood view on both laptops sometimes when I first connect the Toshiba to the wireless AP, but the icons disappear from Neighborhood in a few seconds. I'm using a cardbus wireless D-Link WNA-2330. They are located in the same room with nothing but air between them. The XO is running build 708. I've looked at mailing list archives, but don't see any report like this. Any suggestions?

Change History (5)

comment:1 Changed 12 years ago by overbyte

  • Cc overbyte@… added

comment:2 Changed 12 years ago by overbyte

  • Keywords collaboration LiveCD added

After helpful suggestion from Morgan Collett, I found that the LiveCD is configured with xochat.org as the jabber server and my XO (update.1 build 708) came configured with update1.jabber.laptop.org as the jabber server. (I confirmed that this is a non-existant server -- it won't ping back.) I changed the LiveCD setting using the GUI control panel to be the same as the XO's ex-factory setting. Then as required, I clicked on the Restart button and Sugar restarted (not rebooted). But the Neighborhood view still didn't show either computer on the other, even after waiting for some networking dialog. Next, on the Toshiba's Neighborhood, I clicked to connect to my wireless access point (AP). It connected, and then the icons for the computers appeared on each other's Neighborhood view and stayed there, unlike in the past. This now makes sense to me. The LiveCD laptop and the XO can't connect peer-to-peer because they don't both have 802.11s networking. Instead, they go through the router of my LAN to reach each other. I don't understand why the jabber settings have to be identical, but that seemed to do the trick. However, all is still not well. They don't reliably collaborate on activities. I've tried the 081112 LiveCD iso and and the 080607 LiveCD (build 708 like my XO has) but neither performs invitations and collaboration the way it's described in Sugar docs; mostly not at all. Collaboration should "just work" out of the box. Instead, it's very frustrating.

comment:3 Changed 12 years ago by morgs

  • Cc morgan.collett@… added

I've mailed the livebackup-xo-cd list with this ticket reference.

comment:4 Changed 12 years ago by sascha_silbe

  • Cc sascha-web-dev.sugarlabs.org@… added

comment:5 Changed 12 years ago by marcopg

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Resolution set to invalid
  • Severity set to Blocker
  • Status changed from new to closed

This looks distribution specific, should be reported to the livecd developers.

Note: See TracTickets for help on using tickets.