Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#507 closed defect (fixed)

Joining shared Activity shifts activity icon by few pixels each time, icons can end up off screen

Reported by: garycmartin Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.84.x
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Best explained with a test case:

  • Two Sugar clients attached to a working jabber server so both can see each others buddy icon
  • On client A, start chat and share
  • On client B, go to neighbourhood view and join the shared chat activity
  • On client B, switch back to neighbourhood view
  • On client A, switch from chat to to Journal (alt tab is a good way to repeat this, can be any other activity you switch to) and then switch back to chat again
  • On client B notice that the shared chat activity icon drifts across the screen by a few pixels to the right and a few pixels down
  • On client A, repeat switching back and forth between the shared chat and another Activity while watching the neighbourhood view on client B
  • Each time client A buddy icon moves back to the shared icon, the activity icon will drift right and down by a few pixels

If the Activity icon started close to the right or bottom edge it may disappear off screen. Returning buddy icons will also get vertically further and further away from the activity icon so they are no longer even near each other. If you run this test with more than two Sugar clients sharing the activity, their icon arrangement will also be compromised at the screen edge causing them to cramp up and overlap.

(test environment: two F11 XOs running Sugar 0.84.0)

Change History (3)

comment:1 Changed 12 years ago by FGrose

  • Milestone changed from Unspecified by Release Team to 0.86

comment:2 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this issue in sugar 0.98

When the user on client A switch to another activity, the XO icon in client B moves randomly, but inside the screen.

Closing, reopen if needed.

comment:3 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.