Opened 8 years ago

Closed 8 years ago

#4629 closed defect (fixed)

Sugar: Activities updater not working in AU1B

Reported by: godiard Owned by:
Priority: High Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: AU1B
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The updater in our last image show a activity to update, but finish with "0 activites updated" and the activity is not updated.

With log enabled, shell.log show:

1378994485.774058 DEBUG Updater: Use backend microformat.MicroformatUpdater
1378994485.843876 DEBUG microformat: Query http://wiki.laptop.org/go/Activities/OLPCAU/ARM-test-addons/13.2.0 'http://wiki.laptop.org/go/Activities/OLPCAU/ARM-test-addons/13.2.0'
1378994488.204085 DEBUG microformat: Found 39 activities
1378994488.210581 DEBUG microformat: 1 results after filter
1378994488.215878 DEBUG microformat: Check mulawa.Letters
1378994488.216644 DEBUG microformat: Performing async size lookup
1378994490.639281 DEBUG Updater: _backend_finished_cb
1378994490.640580 DEBUG root: ActivityUpdater.__updates_available_cb
1378994494.136161 DEBUG Updater: Starting update of 1 activities
1378994494.138792 DEBUG Updater: Downloading update for mulawa.Letters
1378994502.092264 DEBUG root: autoconnect Sugar Ad-hoc: already connected
1378994503.890591 DEBUG Updater: Installing update for mulawa.Letters
1378994503.900590 DEBUG root: locale/es_UY.UTF-8/activity.linfo not found.
1378994503.905738 DEBUG root: locale/es_UY/activity.linfo not found.
1378994503.906979 DEBUG root: locale/es.UTF-8/activity.linfo not found.
1378994503.908344 DEBUG root: locale/es/activity.linfo not found.
1378994503.924528 DEBUG root: InstallQueue task mulawa.Letters installed <sugar3.bundle.activitybundle.ActivityBundle object at 0xc55950>
1378994503.925808 DEBUG root: No upgrade needed, same version already installed.
1378994503.927904 DEBUG Updater: mulawa.Letters installed: False
1378994503.945587 DEBUG Updater: Update finished
1378994503.946053 DEBUG root: ActivityUpdater.__finished_cb

Change History (1)

comment:1 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

This problem was due to a mismatch between the Version Number in the database [1] and the actual version number in the activity bundle. The activity is version 24.2, but the database referenced version 26.2. So the updater thought there was a new version, but when it downloaded the new version from the download link, it was the same as the old version, hence it failed to install. Fixed in [1]

[1] http://wiki.laptop.org/go/Activities/OLPCAU/ARM-test-addons/13.2.0

Note: See TracTickets for help on using tickets.