Opened 8 years ago

Closed 7 years ago

#4565 closed defect (fixed)

Browse: Saved password cannot be overridden

Reported by: DeepakMuddha Owned by: walter
Priority: Normal Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Major Keywords: AU1B
Cc: gonzalo, DeepakMuddha Distribution/OS: Unspecified
Bug Status: Assigned

Description

Seen on an XO-1.75 with OE OS 1.2 with Browse 129.3. First step is to test with GTK+ 3 Browse on an XO-4. If there is still a bug, we'll assign to a developer.
Steps to reproduce:

1.connect the XO to a network that has an authenticated WPAD proxy
2.in the Proxy applet in the CP, set the automatic proxy URL
3.launch Browse and try and visit a Web site
4.the proxy password prompt will appear
5.type an incorrect username
6.tick the box to save the credentials, and click OK
7.the authentication will fail, and the authentication box will return
8.enter the correct details and click OK
9.your Web site will appear
10.close Browse and open it again

What should happen: the correct credentials should have been remembered and automatically used to access the Web. The second (correct) entry of credentials should have overridden the first (incorrect) entry in the passwords manager.

What actually happened: the prompt shows again, with the first (incorrect) credentials inserted.

https://sugardextrose.org/issues/4053

Change History (3)

comment:1 Changed 8 years ago by manuq

I tried to reproduce this but I couldn't. Maybe the issue is in the proxy server?

I used Browse to authenticate with gmail and with bugs.sugarlabs.org. In both I did:

  • start Browse
  • navigate to the authentication page
  • type a correct user name and a wrong password -> authentication fails
  • type a correct password -> authentication succeeds
  • stop Browse
  • restart Browse

In the case of gmail, I ticked the checkbox "remember me". After restart, I am already logged in. In the case of bugs.sl.org, there is no "remember me" checkbox; after restart I'm not logged in, as expected.


Last edited 8 years ago by manuq (previous) (diff)

comment:2 Changed 7 years ago by godiard

Deepak,
can you re test?

comment:3 Changed 7 years ago by DeepakMuddha

  • Bug Status changed from New to Assigned
  • Resolution set to fixed
  • Status changed from new to closed

Tested using browse 155 in build 18

I can't reproduce this issue by following the steps mentioned in comment-1.

Note: See TracTickets for help on using tickets.