Opened 8 years ago

Closed 8 years ago

#4564 closed defect (invalid)

Modification in activity.py code break activities

Reported by: DeepakMuddha Owned by: walter
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Major Keywords: AU1B
Cc: gonzalo, DeepakMuddha Distribution/OS: Unspecified
Bug Status: New

Description

I received a report of MusicKeyboard not working in the last AU image (32041oe4.zd)

This is due to a modification in the method _adapt_window_to_screen, in sugar3.activity.py.

The code use a list (ACTIVITIES_NOT_REQUIRING_OSK_ACCUMULATION) and if the activity
is not in the list, try to resize the screen. This issue break MusicKeyboard,
because try to resize a non exisiting (yet) object.

I don't understand why this change was done, a explanation should be good.

This is a clear example about why is better be so close to upstream as possible...

I don't know if this change is related to the problem QA see in physics and Walter can't reproduce

https://sugardextrose.org/issues/4057

Change History (1)

comment:1 Changed 8 years ago by walter

  • Resolution set to invalid
  • Status changed from new to closed

This patch was never pushed upstream, so it is not a Sugar bug. The intention of this patch was to better handle OSK for activities that did not have good OSK support. Although the patch itself is flawed, we do need to add better OSK for some activities, e.g. Terminal and Chat.

Note: See TracTickets for help on using tickets.