Opened 8 years ago

Closed 8 years ago

#4506 closed defect (fixed)

Clock manual hand mode sometimes reports incorrect hours

Reported by: garycmartin Owned by: garycmartin
Priority: Normal Milestone: Unspecified
Component: Clock Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Clock-13, 14, (and likely the intermediate version from Gonzalo) still has an intermittent bug when using manual clock hand mode where the user gets to position the hands. If the time is displayed in text and/or speech is activated, some positions of the analogue hands will result in the digital time being reported one hour out. This (I think) is due to a design flaw where the manual mode time is calculated from the angles of the hour and minute clock hands, this results in rounding up/down errors particularly for the hour hand.

I have a partial patch, but it still has some edge cases that I'm trying to solve.

Change History (1)

comment:1 Changed 8 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in mainline by commit 5a6d5a, will be in release Clock-15

Note: See TracTickets for help on using tickets.