Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4284 closed defect (fixed)

Activity Palette does not appear

Reported by: danielfrancis Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Blocker Keywords: easy-hacks? reproducible
Cc: Distribution/OS: Unspecified
Bug Status: Resolved

Description

Steps to reproduce:

  • Move to the Home List View
  • Right click in an Activity.

Reproducible: Always.

Quotation from the log (These trace appears many times in the same log):

Traceback (most recent call last):

File "/home/danielfrancisp/sugar-build/install/lib/python2.7/site-packages/sugar3/graphics/palettewindow.py", line 1397, in motion_notify_event_cb

self.notify_mouse_enter()

File "/home/danielfrancisp/sugar-build/install/lib/python2.7/site-packages/sugar3/graphics/palettewindow.py", line 960, in notify_mouse_enter

self._ensure_palette_exists()

File "/home/danielfrancisp/sugar-build/install/lib/python2.7/site-packages/sugar3/graphics/palettewindow.py", line 955, in _ensure_palette_exists

palette = self.parent.create_palette()

File "/home/danielfrancisp/sugar-build/install/lib/python2.7/site-packages/jarabe/desktop/activitieslist.py", line 303, in create_palette

palette = ActivityListPalette(registry.get_bundle(bundle_id))

File "/home/danielfrancisp/sugar-build/install/lib/python2.7/site-packages/jarabe/desktop/activitieslist.py", line 503, in init

self.menu.append(self._favorite_item)

AttributeError: 'NoneType' object has no attribute 'append'
Traceback (most recent call last):

File "/home/danielfrancisp/sugar-build/install/lib64/python2.7/site-packages/gi/_gobject/init.py", line 259, in obj_get_property

return prop.fget(self)

File "/home/danielfrancisp/sugar-build/install/lib/python2.7/site-packages/sugar3/graphics/palette.py", line 391, in get_menu

assert self._content_widget is None

AssertionError

Change History (7)

comment:1 follow-up: Changed 8 years ago by manuq

Which build are you using? I can't reproduce with sugar from git.

comment:2 in reply to: ↑ 1 Changed 8 years ago by danielfrancis

Replying to manuq:

Which build are you using? I can't reproduce with sugar from git.

I'm using sugar-build. Just doing the GCI task about multiple home views I noted that error in the log and I confirmed it without my code modifications.

comment:3 follow-up: Changed 8 years ago by dnarvaez

I sent a patch on the mailing list a while ago.

comment:4 in reply to: ↑ 3 Changed 8 years ago by danielfrancis

  • Bug Status changed from Unconfirmed to Resolved

Replying to dnarvaez:

I sent a patch on the mailing list a while ago.

Was your patch applied? A link to the commit is sufficient to close this ticket.

comment:5 Changed 8 years ago by erikos

  • Milestone changed from Unspecified by Release Team to 0.98

Pushed as 73191b0dcd0dfa964ba6467c72db43277915aaad

This issue can be seen in sugar-build, on the XO the Palette works fine even without this patch - this should be investigated. Leaving this ticket open for this.

comment:6 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.