Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#4285 closed defect (fixed)

Updater extension: read_async issue

Reported by: manuq Owned by: manuq
Priority: Low Milestone:
Component: Sugar Version: Unspecified
Severity: Critical Keywords: regression
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

TestCase: go to My Settings, click on Software Upater.

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/controlpanel/gui.py", line 355, in __select_option_cb
    self.show_section_view(option)
  File "/usr/lib/python2.7/site-packages/jarabe/controlpanel/gui.py", line 251, in show_section_view
    self._options[option]['alerts'])
  File "/usr/share/sugar/extensions/cpsection/updater/view.py", line 71, in __init__
    self._refresh()
  File "/usr/share/sugar/extensions/cpsection/updater/view.py", line 161, in _refresh
    self._model.check_updates()
  File "/usr/share/sugar/extensions/cpsection/updater/model.py", line 69, in check_updates
    self._check_next_update()
  File "/usr/share/sugar/extensions/cpsection/updater/model.py", line 82, in _check_next_update
    aslo.fetch_update_info(bundle, self.__check_completed_cb)
  File "/usr/share/sugar/extensions/cpsection/updater/backends/aslo.py", line 164, in fetch_update_info
    _fetcher = _UpdateFetcher(bundle, completion_cb)
  File "/usr/share/sugar/extensions/cpsection/updater/backends/aslo.py", line 93, in __init__
    self._file.read_async(self.__file_read_async_cb)
  File "/usr/lib/python2.7/site-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: read_async() takes exactly 5 arguments (2 given)

Change History (10)

comment:1 Changed 8 years ago by manuq

  • Milestone changed from 0.98 to 1.0

comment:2 Changed 8 years ago by manuq

  • Milestone changed from 1.0 to 0.98

comment:3 Changed 8 years ago by erikos

  • Priority changed from Unspecified by Maintainer to Normal

comment:4 Changed 8 years ago by humitos

  • Cc humitos added

This issue is related with the port from "import gio" to "from gi.repository import Gio". I've already dealt with that in ticket #4242. Maybe that helps.

comment:5 Changed 8 years ago by godiard

  • Priority changed from Normal to Low

Low priority because is not used in olpc images

comment:6 follow-up: Changed 8 years ago by satellit

This is important to have for fedora 18 sugar-desktop and the fedora 18 Sugar on a Stick spin however.

comment:7 in reply to: ↑ 6 Changed 8 years ago by satellit

Replying to satellit:

This is important to have for fedora 18 sugar-desktop and the fedora 18 Sugar on a Stick spin however.

Especially as #4321 and #4440 have been closed as duplicates of this bug

comment:9 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed

comment:10 Changed 7 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.