Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4243 closed defect (duplicate)

Terminal starts wrongly OS12

Reported by: tonyforster Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone:
Component: Terminal Version: Unspecified
Severity: Unspecified Keywords:
Cc: tonyforster Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

XO-1.75 OS12 Terminal41

Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/sugar3/activity/activity.py", line 538, in canvas_map_cb

self.read_file(self._jobject.file_path)

File "/home/olpc/Activities/Terminal.activity/terminal.py", line 401, in read_file

self._create_tab(tab_state)

File "/home/olpc/Activities/Terminal.activity/terminal.py", line 342, in _create_tab

vt.feed(l + '\r\n')

File "/usr/lib/python2.7/site-packages/gi/types.py", line 47, in function

return info.invoke(*args, kwargs)

TypeError: Item 0: Must be number or single byte string, not unicode

Attachments (2)

Screenshot of %22Terminal Activity%22.png (14.9 KB) - added by tonyforster 8 years ago.
Terminal Activity.asc (2.2 KB) - added by tonyforster 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by tonyforster

comment:1 Changed 8 years ago by tonyforster

  • Component changed from untriaged to Terminal
  • Owner set to RafaelOrtiz

comment:2 Changed 8 years ago by dsd

  • Milestone changed from Unspecified by Release Team to 0.98

comment:3 Changed 8 years ago by humitos

  • Cc tonyforster added
  • Resolution set to invalid
  • Status changed from new to closed

I couldn't reproduce this in:

  • XO-4 os15
  • XO-1.75 os14
  • XO-1.5 os15

Closing. If this still happen to you, please reopen it. Thanks.

comment:4 Changed 8 years ago by tonyforster

also present on xo-1.75 os14, I will reinstall terminal and test again

Changed 8 years ago by tonyforster

comment:5 Changed 8 years ago by tonyforster

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:6 follow-ups: Changed 8 years ago by tonyforster

Its a corrupt journal entry. Faulty form resume but not start new. I have reopened because ideally, a corrupt journal entry should not prevent terminal starting. Journal entry is attached

comment:7 in reply to: ↑ 6 Changed 8 years ago by humitos

  • Resolution set to duplicate
  • Status changed from reopened to closed

Replying to tonyforster:

Its a corrupt journal entry. Faulty form resume but not start new. I have reopened because ideally, a corrupt journal entry should not prevent terminal starting. Journal entry is attached

OK. Terminal is not working well with resume / save session. That problem is tracked here: #4131

comment:8 in reply to: ↑ 6 Changed 8 years ago by humitos

Replying to tonyforster:

Its a corrupt journal entry. Faulty form resume but not start new.

Please, write down a test case for this. I tried to reproduce what you got but I couldn't.

comment:9 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.