Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4124 closed defect (fixed)

Write-82 typing input slows down after about half a page of plain text

Reported by: garycmartin Owned by: godiard
Priority: High Milestone:
Component: Write Version: Unspecified
Severity: Unspecified Keywords: 13.1.0, regression, olpc-test-passed
Cc: greenfeld Distribution/OS: Unspecified
Bug Status: Assigned

Description

In Write-82 typing input noticeable slows down after writing about half a page of plain text. Typing gets slower and slower and the keyboard buffer starts to fill up. Copy and paste are not yet working so it's hard to generate a lot of text, but I hate to think how slow it will be after a page or two. Tested with just plain text is the default font and size, not formatting changes.

Change History (12)

comment:1 Changed 8 years ago by garycmartin

Tested on XO-4 13.1.0 build 8 using the physical keyboard to input text (XO in laptop mode)

comment:2 Changed 8 years ago by godiard

  • Priority changed from Unspecified by Maintainer to High

comment:3 Changed 8 years ago by garycmartin

  • Cc greenfeld added
  • Keywords regression added

Testing in Build 12, Write 83, XO-1.75 and XO-4 hardware:

Write is still running very slowly once you have typed about half a page of text in the default font, no formatting changes. The screen gets many characters behind the input buffer using either the physical keyboard or the OSK.

Additional testing seems to indicate that the slow down is due to the spelling error red under line effect (this was disabled by default in previous builds due to lack of language dictionaries). Due to the lack of any copy/paste I have often been testing by typing random letters followed by spaces to make filler text like paragraphs, most of which are underlined red, after about eight lines of text the typing slow down is very obvious. Typing known word spellings (no red line effect) did not significantly slow down text input when tested up to one page of text (though there was some reduction in improvement).

Suggest disabling the red underline spelling error checks and re-testing, unless its performance can be improved. And certainly suggest performance testing with a number of larger, multipage documents, to assure we ship a usable word processor for school level work.

comment:4 Changed 8 years ago by greenfeld

Within the past few months Fedora 18 (or OLPC) took an AbiWord build which seemed to add a lot of visible functionality (RDF support, etc.).

This reproduces on a XO-1.5, but I am a bit hesitant about using ARM-based XOs as a reference right now for Write because AbiWord crashes on them (12311).

OLPC uses a custom Abiword RPM, even on x86 XOs that do not have mallit. It would be worth seeing if this reproduces outside of a XO environment or without the custom abiword/libabiword RPMs.

comment:5 Changed 8 years ago by erikos

We should be able to rebuild the abiword rpm with '--disable-spell' (Gtk+ only) do not include spell checking support.

If that is the desired behaviour.

comment:6 Changed 8 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned

Current behaviour (os15):

  • in English: non-english or faulty-english text is underlined, there is no way in getting suggestions to correct the spelling
  • another locale (e.g. German): no text is underlined

rpms built with the '--disable-spell' option: http://dev.laptop.org/~gonzalo/olpc7/

  • no text is spell-checked
  • this is the same behaviour as in 12.1.0

Summary:

I would disable spell-checking until we have a way to correct the spelling. We should check as well spell checking for different locales (might be that just installing a dictionary is needed).

comment:7 follow-up: Changed 8 years ago by godiard

Probably is not a regression against 12.1.0, but spell checking was a feature in older sugar versions. I think we need add support in olpc-build to add the dictionary rpms for the selected languages, and check if is needed use hunspell or aspell dictionaries right now.

A new rpm will be build with --disable-spell and the other changes needed.

comment:8 in reply to: ↑ 7 Changed 8 years ago by garycmartin

Replying to godiard:

Probably is not a regression against 12.1.0, but spell checking was a feature in older sugar versions.

To my knowledge spell checking had been disable for past OLPC releases, there are plenty of email threads and blog posts out there for those that wanted to tinker and re-enable. Perhaps some deployments customised this aspect of their builds. From what I can remember of the original discussions, it was disabled based on lack of good free multi-lingual dictionaries, vs storage space, vs properly implementing the feature in Write (e.g. UI for getting suggestions, adding to and editing a local users dictionary), vs pedagogical discussion about how highlighting of spelling mistakes (and suggesting the correct spelling) may actually be re-enforcing spelling errors (I din't follow the complete argument there).

+1 for disabling the spelling detection until we have more time to land the feature and test it correctly.

comment:9 Changed 8 years ago by godiard

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

The last rpms [1] have spell checking disable and don't show this problem

[1] http://dev.laptop.org/~gonzalo/olpc11/

comment:10 follow-up: Changed 8 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Spell checking is disabled (and things seem slightly faster) but I am not certain we got at the root of this problem.

In general using Write on XO-1 has become quite slow, especially once you start trying to add pictures/etc. in the mix.

Other XO models (such as XO-1.5) are relatively quick with plain text but start slowing down once non-text elements are added.

comment:11 in reply to: ↑ 10 Changed 8 years ago by godiard

Replying to greenfeld:

Spell checking is disabled (and things seem slightly faster) but I am not certain we got at the root of this problem.

In general using Write on XO-1 has become quite slow, especially once you start trying to add pictures/etc. in the mix.

Other XO models (such as XO-1.5) are relatively quick with plain text but start slowing down once non-text elements are added.

It's slower than Write in 12.1.0?

comment:12 Changed 8 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.