Opened 8 years ago

Closed 8 years ago

#4095 closed enhancement (fixed)

Turtleart touchscreen no OSK

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Editing a text block with XO-4 OS7 TA160 in ebook mode does not bring up the touchscreen on screen keyboard. I think we want the OSK for number blocks too.

Change History (19)

comment:1 Changed 8 years ago by walter

This is enabled with the latest (unreleased) bits. I have a bit more cleaning up to do before I make the final release of this feature, but you can grab the code from git if you want to do some testing.

Note that the implementation involves overlaying a Gtk.TextView over the text and number blocks.

comment:3 Changed 8 years ago by tonyforster

Thanks, upgraded to V162 and it seems to work, unfortunately the font while editing is too big

comment:4 Changed 8 years ago by tonyforster

It might be better if when you close the keyboard you finish editing, that is the block text reverts to green background and normal font?

comment:5 Changed 8 years ago by walter

Please upgrade to v164, which should fix the scaling problem (and a problem with the triangles)

comment:6 Changed 8 years ago by tonyforster

I am getting V162 as the highest version on ASLO.

The OSK covers the block being edited. How do other tablets handle this? One solution would be to scroll the block being edited to the upper screen and scroll back when the OSK closes. (Fast zooming and scrolling may turn out to be the key to satisfactory tablet performance.)

comment:7 Changed 8 years ago by walter

Oops. Forgot to release v164... will do so shortly.

Re the problem with occlusion, it is being addressed at the Sugar level, so I am ignoring it for the time being in TA

comment:8 Changed 8 years ago by tonyforster

The tool tips at the bottom of the screen have got larger at some point.

Numeric block is now accepting alpha characters, I think this is a change, maybe ok. Better if it exited edit mode for enter? (but dont change text block ability to accept multiline strings)

Better if closing OSK exited edit mode?

comment:9 follow-up: Changed 8 years ago by walter

Should all be OK in v167.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 8 years ago by tonyforster

Replying to walter:

Should all be OK in v167.

The latest on ASLO is v166

comment:11 in reply to: ↑ 10 Changed 8 years ago by tonyforster

Replying to tonyforster:

Replying to walter:

Should all be OK in v167.

The latest on ASLO is v166

Its OK, I see you sent me V167 in a PM on 8 Nov, sorry

comment:12 Changed 8 years ago by tonyforster

If you quit the osk with its lower right button and then reedit then quit again, its possible to get the text block half white and half green.

It would be better if quitting the osk (with its bottom right button) terminated edit mode, its the expected behaviour and it gets rid of the display issue mentioned above.

comment:13 follow-up: Changed 8 years ago by walter

I agree. I just don't know how to detect that the OSK has been dismissed. Will keep looking for that event flag.

comment:14 in reply to: ↑ 13 Changed 8 years ago by tonyforster

Replying to walter:

I agree. I just don't know how to detect that the OSK has been dismissed. Will keep looking for that event flag.

The textbox that holds the Activity title seems to know, it changes from white to grey presumably indicating that it has lost focus

comment:15 Changed 8 years ago by walter

I've started working on a fix... will let you know when the patch lands.

comment:16 Changed 8 years ago by walter

Should be working with the latest patch [1]. I treat number blocks a bit differently, since if I unselect the block on focus-out, the triangles go away as well. So for the time being, you need to click off of the block as well. Let me know what you think.

[1] http://git.sugarlabs.org/turtleart/mainline/commit/357da6f6e28f4a8ff65e8972bc8641f2161ace65

comment:17 Changed 8 years ago by tonyforster

Thanks. Text blocks OK. Not sure about number blocks. Are you saying you purposefully dont dismiss the triangles when you close the OSK? Or that the triangles wouldnt appear without the OSK otherwise? Ideally closing the OSK should dismiss the triangles IMO

How useful are the triangles now there is an OSK? They are only useful for numbers 1-10, so in most cases they will be used for repeat but not fwd or right. They are only useful on a XO-4 in non-ebook mode. My fat finger misses the triangle mostly.

comment:18 Changed 8 years ago by walter

Maybe it is time to lose the triangles. I was thinking of adding some sort of gesture from the arrows to increments > 1, but it is not a priority at this point... So I'll make number blocks behave like the text blocks.

comment:19 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Should be all set in v167 release.

Note: See TracTickets for help on using tickets.