Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4040 closed defect (fixed)

Journal details view: description and tags not being committed

Reported by: erikos Owned by: manuq
Priority: Urgent Milestone:
Component: Sugar Version: 0.97.x
Severity: Blocker Keywords: regression, 13.1.0, r+, olpc-test-passed
Cc: erikos Distribution/OS: OLPC
Bug Status: Assigned

Description (last modified by manuq)

Build: vanilla os6

Steps to reproduce:

  • go to the Journal
  • go to the detail view of an entry
  • type a keyword into the description field
  • go back to the main view
  • search for that keyword

---> the entry should be displayed as one of the matches

Attachments (3)

0001-Journal-details-view-Update-entry-when-description-o.patch (1.7 KB) - added by manuq 10 years ago.
Candidate patch
0002-Journal-details-view-Remove-unneeded-style-for-title.patch (1.1 KB) - added by manuq 10 years ago.
Cleanup patch, remove unneeded styling from the code
0003-Journal-details-view-PEP8-fixes-long-lines.patch (1.7 KB) - added by manuq 10 years ago.
Cleanup patch 2, PEP8 fix, long lines

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by erikos

  • if you change the title as well, the description can be searched for.
  • if you switch back between details/listview the set description can go away
  • ful text search (e.g. a document in the Write activity) is working

comment:2 Changed 10 years ago by manuq

  • Description modified (diff)
  • Summary changed from Journal: description is not part of the full text search to Journal details view: description and tags not being committed

Changed 10 years ago by manuq

Candidate patch

Changed 10 years ago by manuq

Cleanup patch, remove unneeded styling from the code

Changed 10 years ago by manuq

Cleanup patch 2, PEP8 fix, long lines

comment:3 Changed 10 years ago by manuq

  • Cc erikos added
  • Keywords 13.1.0 r? added

comment:4 Changed 10 years ago by erikos

  • Keywords r+ added; r? removed

Please get them in! :)

comment:5 Changed 10 years ago by manuq

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

Thanks for your review Simon. Pushed b112457e .

TestCase:

  • go to details of entry A, change description
  • go back to list
  • go to another entry details
  • go back to details of A

The new description should be displayed. Since dehippo the old description was displayed, because the new one was not being committed.

comment:6 Changed 10 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Fixed in OLPC 13.1.0 os9.

comment:7 Changed 10 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.