Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3961 closed defect (fixed)

sugar-toolkit-gtk3: utf8 srings in gtk3 apps conflict

Reported by: godiard Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.97.x
Severity: Unspecified Keywords: olpc-test-passed
Cc: Distribution/OS: OLPC
Bug Status: Resolved

Description

Pygi does not set the default encoding anymore as the old GTK+ did. This change does break activities ported to GTK+3.
This topic was discussed in sugar-devel [1]
The change in GTK+ has been discussed upstream here [2].

The sugar-toolkit-gtk3 patch was pushed as 5fdad9481ba7079a6a718159ebe7eb8e5367c46e

[1] http://lists.sugarlabs.org/archive/sugar-devel/2012-August/038993.html
[2] https://bugzilla.gnome.org/show_bug.cgi?id=681915

TestCase:

1) Set Sugar language to Spanish
2) Open GetBooks (Obtener Libros)
3) Select any catalog and one book.

Without the patch in sugar-toolkit-gtk3, the book description at the bottom of the screen is not displayed. This is because the translation of "Title" is "Título".
In the activity log, you can see:

Traceback (most recent call last):

File "/home/gonzalo/Activities/GetBooks.activity/GetIABooksActivity.py", line 646, in selection_cb

self.show_book_data()

File "/home/gonzalo/Activities/GetBooks.activity/GetIABooksActivity.py", line 657, in show_book_data

book_data = _('Title:\t\t') + self.selected_title + '\n'

UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal not in range(128)

With the patch applied in sugar-toolkit-gtk3 the description is displayed ok.

Change History (5)

comment:1 Changed 7 years ago by erikos

  • Bug Status changed from Unconfirmed to Resolved
  • Distribution/OS changed from Unspecified to OLPC
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from Unspecified to 0.97.x

Pushed as 5fdad9481ba7079a6a718159ebe7eb8e5367c46e, will be in sugar-toolkit-gtk3-0.97.4

comment:3 Changed 7 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

The Getbooks scenario mentioned works in 13.1.0 os7.

comment:4 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar

comment:5 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.