Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3932 closed defect (fixed)

Browse tabs, label text should not be multiline

Reported by: manuq Owned by: manuq
Priority: Normal Milestone:
Component: Browse Version: Unspecified
Severity: Unspecified Keywords: 13.1.0, theme, r?
Cc: garycmartin, humitos, erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

We have to make sure the title in the tabs is in one line.

Attachments (1)

0002-Force-GtkLabel-inside-notebook-tab-to-be-in-one-line.patch (1.0 KB) - added by manuq 7 years ago.
Candidate patch

Download all attachments as: .zip

Change History (12)

comment:1 in reply to: ↑ description Changed 7 years ago by garycmartin

Replying to manuq:

We have to make sure the title in the tabs is in one line.

+1 :)

comment:2 Changed 7 years ago by humitos

  • Priority changed from Unspecified by Maintainer to Normal

comment:3 Changed 7 years ago by humitos

  • Cc humitos added

Take a look at #3560

comment:5 Changed 7 years ago by manuq

We found that this can be solved in the theme, setting the right padding to the GtkLabel inside the tabs, and this is something that has to be done, because we need to reach the same tab height as when they have buttons.

.notebook tab GtkLabel {
    color: @white;
+    padding: 10px 0;
}

comment:6 Changed 7 years ago by humitos

  • Owner changed from humitos to manuq
  • Status changed from new to assigned

comment:7 Changed 7 years ago by manuq

  • Keywords theme added

Changed 7 years ago by manuq

Candidate patch

comment:8 Changed 7 years ago by manuq

  • Cc erikos added
  • Keywords r? added

comment:9 follow-up: Changed 7 years ago by garycmartin

Just re-testing the patch here, looks like it has landed already in sugar-artwork. The single line tab text is looking good in Browse, thanks. Can we close this ticket?

comment:10 in reply to: ↑ 9 Changed 7 years ago by manuq

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to garycmartin:

Just re-testing the patch here, looks like it has landed already in sugar-artwork. The single line tab text is looking good in Browse, thanks. Can we close this ticket?

Oh yes, pushed 6932e87d .

comment:11 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.