Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3902 closed defect (fixed)

Fix Language section in Control Panel

Reported by: manuq Owned by: manuq
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

  1. bug removing languages, fix:
--- a/extensions/cpsection/language/view.py
+++ b/extensions/cpsection/language/view.py
@@ -135,7 +135,7 @@ class Language(SectionView):
 
         if self._selected_lang_count > 1:
             previous_add_removes = self._add_remove_boxes[-2]
-            previous_add_removes.hide_all()
+            previous_add_removes.hide()
 
         self._determine_add_remove_visibility()
  1. The view is expanded because of the description label "Add languages in the order you prefer...". In the XO this is odd because you loose the X close buton and you are stuck in the control panel modal window. From this testcase [1] it seems that removing set_width_chars(100) from the label help, but even removing that the container is expanded in Sugar.

[1] http://dev.laptop.org/~manuq/shell-port/testchildexpand.py

Attachments (1)

0001-Fix-layout-of-Language-and-Modem-sections-in-the-Con.patch (2.5 KB) - added by manuq 7 years ago.
Candidate patch

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by manuq

  • Component changed from untriaged to sugar

Changed 7 years ago by manuq

Candidate patch

comment:2 Changed 7 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.