Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3900 closed defect (fixed)

Menu icons are not visible in the XO

Reported by: manuq Owned by: manuq
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.97.x
Severity: Unspecified Keywords:
Cc: erikos, dnavaez, pbrobinson Distribution/OS: Unspecified
Bug Status: Assigned

Description

This is because 'gtk-menu-images' gtk setting is set to False. This doesn't happen running Sugar with sugar-build.

http://developer.gnome.org/gtk3/3.2/GtkImageMenuItem.html#gtk-image-menu-item-set-image

I think Sugar should always set it to True. The question is in which place. In sugar-session we set other settings like the sugar theme and theme icons. The proposed patch makes it there.

Attachments (2)

0001-Add-setting-to-always-show-the-icons-in-the-menu-SL-.patch (980 bytes) - added by manuq 7 years ago.
Proposed patch.
0001-Theme-set-gtk-menu-images-to-True-in-settings.ini-SL.patch (1.2 KB) - added by erikos 7 years ago.
set 'gtk-menu-images' to True in settings.ini

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by manuq

Proposed patch.

comment:1 Changed 7 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Cc dnavaez pbrobinson added
  • Version changed from Unspecified to 0.97.x

I agree that the patch works on the XO. Let's find out why we do not have that issue in sugar-build for example. It is set to True there, outside in GNOME it is set to False.

@Daniel anything fancy we do there?

Would it occur on Fedora/Soas as well?

comment:2 follow-up: Changed 7 years ago by dnarvaez

We don't do anything fancy. I think either we are somehow talking to the "parent" gnome-session xsettings daemon (unlikely) or maybe there is a settings.ini somewhere involved.

Anyway, since this is a static setting, why not just put it in the settings.ini in the theme rather then in code?

comment:3 Changed 7 years ago by erikos

gtk-menu-images should default to True. Looking at the description if there is no XSettings manager (like in the case of Sugar) the defaults are taken from an ini file /etc/gtk-3.0/settings.ini. In the case of the XO the settings.ini sets the "gtk-menu-images" to False. Setting it to True there does show the menu items.

In sugar-build the menu-items are present neverless of "/etc/gtk-3.0/settings.ini" (from adwaita-gtk3-theme-3.4.2-1.fc17.i686) has "gtk-menu-images" set to False. Even when I start sugar-build from a virtual console. Probably it is getting the values from the xsettings manager.

As long as we don't have an xsettings manager we should be safe to set the setting in sugar-session like we do with the theme/icon-theme and the font. We should also check if other seetings hurt us which we don't handle.

[Settings]
gtk-theme-name = Adwaita
gtk-icon-theme-name = gnome
gtk-cursor-theme-name = Adwaita
gtk-button-images = 0
gtk-menu-images = 0
gtk-auto-mnemonics = 0

comment:4 in reply to: ↑ 2 Changed 7 years ago by erikos

Replying to dnarvaez:

We don't do anything fancy. I think either we are somehow talking to the "parent" gnome-session xsettings daemon (unlikely) or maybe there is a settings.ini somewhere involved.

Anyway, since this is a static setting, why not just put it in the settings.ini in the theme rather then in code?

Yes, you are right, putting it there sounds good to me.

Changed 7 years ago by erikos

set 'gtk-menu-images' to True in settings.ini

comment:5 Changed 7 years ago by erikos

Manuel, do you agree with that approach to set 'gtk-menu-images' to True in settings.ini?

comment:6 Changed 7 years ago by manuq

Yes erikos I think this is the right way. Please push.

comment:7 Changed 7 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

Thanks Manuel.

Pushed as: 6ad1090a006fdb32d4686d1f52d00f2c7703e8d1

comment:8 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.