Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3899 closed defect (fixed)

Infoslicer mime type for published content not mapped to install content & launch Browse

Reported by: greenfeld Owned by: walter
Priority: High Milestone:
Component: InfoSlicer Version: Unspecified
Severity: Unspecified Keywords: 13.1.0, regression
Cc: greenfeld, humitos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

The Infoslicer mime type for published content (application/vnd.olpc-content) is not mapped to Browse in 13.1.0 os1.

A published content bundle from Infoslicer appears with a binary icon in the Journal and cannot be "resumed".

Historically some sort of Sugar magic extracted the bundle and updated the list of content prior to showing it in Browse.

Seen in 13.1.0 os1.

Attachments (2)

My info.xol (16.2 KB) - added by greenfeld 7 years ago.
Bundle created from Infoslicer in os20
My info.xol.metadata (502 bytes) - added by greenfeld 7 years ago.
USB metadata stored by Sugar for the same bundle

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by greenfeld

Upon further investigation this was seen on a XO-1.5 and not a XO-1.75 with the same OS build.

I will recheck this once os2 becomes available.

comment:2 Changed 7 years ago by godiard

Duplicate of #3737

comment:3 Changed 7 years ago by godiard

  • Milestone changed from Unspecified by Release Team to 0.98

This is a regression. We need research if is a problem with Infoslicer, Browse or Sugar.

comment:4 Changed 7 years ago by godiard

  • Keywords regression added

comment:5 Changed 7 years ago by humitos

  • Cc greenfeld humitos added

I tested this on:

  • 12.1.0 os21 and I got this Traceback when I click on the Journal entry (binary icon)
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/jarabe/journal/palettes.py", line 132, in __start_activate_cb
        misc.resume(self._metadata)
      File "/usr/lib/python2.7/site-packages/jarabe/journal/misc.py", line 200, in resume
        bundle.install()
      File "/usr/lib/python2.7/site-packages/sugar/bundle/contentbundle.py", line 231, in install
        self._unzip(install_path)
      File "/usr/lib/python2.7/site-packages/sugar/bundle/bundle.py", line 175, in _unzip
        raise ZipExtractException
    sugar.bundle.bundle.ZipExtractException
    
  • 13.1.0 os16 (shows binary icon in the Journal Entry)
    • It worked. I was able to open the Infoslicer content with Browse. I've just clicked on icon.

@greenfeld: what is the correct icon for this Journal entry? are you able to reproduce this issue now?

comment:6 Changed 7 years ago by humitos

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 7 years ago by greenfeld

  • Resolution fixed deleted
  • Status changed from closed to reopened

This still is not working for me in 13.1.0 os20.

The error in shell.log seen starting the bundle is:

Archive:  /home/olpc/.sugar/default/data/955f0311-1912-40a3-bbca-f8ad59e7e417_VRxe2A.xol
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/mapstylesheet.xsl  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/ditastylesheet.xsl  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/ditastyle.css  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/mapstyle.css  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/library/library.info  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/index.html  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/ebb1fe68-4f8b-11e2-8604-2016d81e8909.dita  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/ebb1fe68-4f8b-11e2-8604-2016d81e8909.html   bad CRC 6844fd9e  (should be cc07a1ed)
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/librarymap.ditamap  
 extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/librarymap.html  
caution: excluded filename not matched:  mimetype
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/journal/listview.py", line 578, in __icon_clicked_cb
    misc.resume(metadata)
  File "/usr/lib/python2.7/site-packages/jarabe/journal/misc.py", line 200, in resume
    bundle.install()
  File "/usr/lib/python2.7/site-packages/sugar3/bundle/contentbundle.py", line 231, in install
    self._unzip(install_path)
  File "/usr/lib/python2.7/site-packages/sugar3/bundle/bundle.py", line 175, in _unzip
    raise ZipExtractException
sugar3.bundle.bundle.ZipExtractException

comment:8 Changed 7 years ago by greenfeld

  • Keywords olpc-test-pending removed

Changed 7 years ago by greenfeld

Bundle created from Infoslicer in os20

Changed 7 years ago by greenfeld

USB metadata stored by Sugar for the same bundle

comment:9 Changed 7 years ago by greenfeld

Of note is I tried to install the created bundle on the same XO-4 I made it directly from the journal, and not from the USB stick.

The error message:

extracting: /home/olpc/Library/ebb1bcbe-4f8b-11e2-8604-2016d81e8909/slicecontent/ebb1fe68-4f8b-11e2-8604-2016d81e8909.html   bad CRC 6844fd9e  (should be cc07a1ed)

suggests the ZIP file might not have been properly created in the first place.

comment:10 Changed 7 years ago by humitos

These are the steps that I'm following and I'm not being able to reproduce this issue:

  1. Open InfoSlicer
  2. Click on Giraffe checkbox
  3. Click on 'Publish selected articles'
  4. Go to the Journal
  5. Click on the 'binary' icon with description 'InfoSlicer Activity'

There, Browse starts and show the Giraffe article. I checked the shell.log and there is no traceback there.

I tested this on XO-4 os28 and XO-1.5 os27.

What is the correct icon to show in the Journal instead the 'binary' one?

comment:11 Changed 7 years ago by greenfeld

  • Resolution set to fixed
  • Status changed from reopened to closed

I could not reproduce this on a XO-4 with os29.

Given the bad CRC error seen once, this might have been a processor miscalculation similar to 12164.

comment:12 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.