Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#3868 closed defect (fixed)

Bookmarks toolbar does not appear when bookmark is created

Reported by: greenfeld Owned by: humitos
Priority: Normal Milestone:
Component: Browse Version: 0.97.x
Severity: Unspecified Keywords: patch
Cc: manuq, erikos, humitos Distribution/OS: OLPC
Bug Status: Assigned

Description

In OLPC 13.1.0 os1 I cannot create bookmarks in Browse or Wikipedia (English & Spanish).

The bookmark button does not appear to do anything as the bookmarks bar at the bottom of the screen does not appear.

This may be what is meant in #3855, but it is not like I can see them only to have them be lost as soon as I exit the activity.

Attachments (4)

0001-Show-Bookmark-toolbar-when-a-bookmark-is-added-SL-38.patch (850 bytes) - added by humitos 7 years ago.
0001-Show-Bookmark-toolbar-when-a-bookmark-is-added-SL-38.2.patch (3.0 KB) - added by humitos 7 years ago.
v2 - use ToggleToolButton and set tooltips properly
tray-a.png (3.2 KB) - added by manuq 7 years ago.
New proposed icon
tray-b.png (10.3 KB) - added by manuq 7 years ago.
New proposed icon.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by greenfeld

  • Summary changed from Bookmarks are impossible to create in Browse and Wikipedia to Bookmarks toolbar does not appear when bookmark is created

Actually I take this back.

When resuming from the Journal I see my bookmarks in both Browse & Wikipedia. The Bookmarks toolbar just does not auto-appear when a bookmark is created for the first time.

I think it should appear when a bookmark is created (even if it is currently hidden) so that the user knows what they just did.

comment:2 follow-up: Changed 7 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Keywords 13.1.0 removed
  • Milestone changed from Unspecified by Release Team to 0.98
  • Owner changed from erikos to humitos
  • Status changed from new to assigned
  • Version changed from Unspecified to 0.97.x

Humitos, can you have a look why we do not display the tray automatically?

comment:3 Changed 7 years ago by humitos

  • Priority changed from Unspecified by Maintainer to Normal

comment:4 in reply to: ↑ 2 Changed 7 years ago by humitos

  • Cc manuq erikos humitos added

Replying to erikos:

Humitos, can you have a look why we do not display the tray automatically?

We were showing the Toolbar without elements at start; so when the button was clicked we asked:

if self._tray.props.visible is False:
    self._tray.show()

and it didn't show the toolbar because we were doing "self._tray.show()" at startup without items.

comment:5 Changed 7 years ago by humitos

  • Keywords patch added

comment:6 Changed 7 years ago by manuq

Great, the patch fixes toggling the tray. But the tray button in the view (eye) toolbar does not change its state, and doesn't display the tooltip.

Changed 7 years ago by humitos

v2 - use ToggleToolButton and set tooltips properly

comment:7 Changed 7 years ago by manuq

  • Resolution set to fixed
  • Status changed from assigned to closed

I've found the following issues with your patch:

Removing the last bookmark leaves the tray opened and the tray icon is greyed out so you can't hide it manually. Testcase:

  • start browse from scratch
  • add a bookmark, tray appears
  • remove bookmark (from bookmark palette)

And:

button graphics are inverted, up arrow should hide the tray, and down arrow should show the tray.

So starting with your patch I inverted the way things are done:

Instead of changing the tooltip and icon of the tool button based on the visibility of the tray, with the map and unmap callbacks that this patch removes, do the inverse: when a bookmark is made, the toggle button is activated, and it shows the tray in the toggled callback. Also when the only pending bookmark is removed, the toggle button is deactivated, and it hides the tray in the toggled callback.

The switch to a toggle button allows us to do the tray and button interaction in a more standard way, and the bugs that the unconventional interaction raised are now fixed.

Pushed it as 49495aa4, thanks.

Changed 7 years ago by manuq

New proposed icon

Changed 7 years ago by manuq

New proposed icon.

comment:8 Changed 6 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.