Opened 9 years ago

Closed 9 years ago

#3568 closed defect (fixed)

Some cards dissapear

Reported by: humitos Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Visual Match Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

  1. Open Visual Match
  2. Close the welcome message
  3. Start a new expert game
  4. Click many times (like a crazy guy :-)) over all the cards of the game

Issue:

Some of those cards clicked go outside the screen and you can't recover them

Expected behavior:

Those cards should return to their original position on the table or another position, but inside the game :)

Environment:

jhbuild on Debian Testing with the git version (2dd06d26d86e06a77c9438823c98a4d61c3cccde)

Change History (6)

comment:1 follow-up: Changed 9 years ago by humitos

The problem is when you click over a card, it starts going to the left and you click over it again. The card goes outside the screen.

comment:2 in reply to: ↑ 1 Changed 9 years ago by humitos

Replying to humitos:

The problem is when you click over a card, it starts going to the left and you click over it again(*). The card goes outside the screen.

(*) before it reaches the final path position.

comment:3 follow-up: Changed 9 years ago by walter

This patch [1] should catch many of the disappearing card issues... please test.

[1] http://git.sugarlabs.org/visualmatch/mainline/commit/530c0b4f4632c36dd4805325abad7d45ed32f5c0

comment:4 in reply to: ↑ 3 Changed 9 years ago by humitos

Replying to walter:

This patch [1] should catch many of the disappearing card issues... please test.

Applying this patch I have this issue.

When you click the third right card they just disappear instead showing the "win" smiles.

comment:5 Changed 9 years ago by walter

After a series of patches, I think this is OK now. Please pull the latest bits from git to test.

comment:6 Changed 9 years ago by humitos

  • Resolution set to fixed
  • Status changed from new to closed

Great! It seems that those patches fix this issue. I couldn't reproduce it anymore: I clicked on every things more than twice. Closing this ticket.

I found another issue testing this one. Look at this ticket please: #3579

Note: See TracTickets for help on using tickets.