Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3473 closed defect (fixed)

Browse: drop-down list of suggested pages issue

Reported by: manuq Owned by: manuq
Priority: Low Milestone:
Component: Browse Version: Unspecified
Severity: Minor Keywords: 12.1.0, olpc-test-passed
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Start typing in the web url entry and then go down the list using the down arrow key, then go up using up arrow key. When up arrow key is pressed, the list disappears.

Log attached with the traceback.

Attachments (4)

org.laptop.WebActivity-4.log (6.2 KB) - added by manuq 8 years ago.
browse--drop-down-list-of-suggested-pages-issue.patch (886 bytes) - added by humitos 8 years ago.
This will be the patch when the bug be fixed
treemodel_test.py (1.8 KB) - added by humitos 8 years ago.
Test csae of the pygi bug we did with manuq
pygobject3-3.0.3-2.fc16.i686.rpm (237.8 KB) - added by humitos 8 years ago.
RPM package containing the patch mentioned in this ticket that fixed the problem with GtkTreeModel - Thanks to manuq for his help

Download all attachments as: .zip

Change History (18)

Changed 8 years ago by manuq

comment:1 Changed 8 years ago by manuq

  • Milestone changed from Unspecified by Release Team to 0.96

comment:2 Changed 8 years ago by humitos

  • Cc humitos added

comment:3 Changed 8 years ago by humitos

I reported a bug on pygobject that it's related with this:

Changed 8 years ago by humitos

This will be the patch when the bug be fixed

Changed 8 years ago by humitos

Test csae of the pygi bug we did with manuq

Changed 8 years ago by humitos

RPM package containing the patch mentioned in this ticket that fixed the problem with GtkTreeModel - Thanks to manuq for his help

comment:5 Changed 8 years ago by humitos

You can download the RPM package and install it with:

sudo yum install pygobject3-3.0.3-2.fc16.i686.rpm

comment:6 Changed 8 years ago by manuq

And here are RPMs for F17 built with koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4030865

comment:7 Changed 8 years ago by manuq

RPM and Browse patch tested in XO-1.5 os8, the bug is gone.

comment:8 Changed 8 years ago by manuq

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

Thanks humitos, the pygobject part was pushed in master as d37680bb9390426f7f58ea3d352c3e5e2106e978 . The Browse part is now pushed as c9e19a4da890cd528e1ff70697f28470aa18217e .

comment:9 Changed 8 years ago by erikos

The pygobject fix has been cherry-picked to the 3.2. branch. The stable branch will be released at the same time as the upcoming gnome 3.4.2 release.

comment:10 Changed 8 years ago by greenfeld

  • Keywords olpc-test-pending removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

When I press the up key the list still disappears in 12.1.0 os10/Browse-137.

comment:11 Changed 8 years ago by humitos

What do we have to do to include the RPM patched version on our release? Because I think the problem here is os10 doesn't have the RPM patched verion

comment:12 Changed 8 years ago by manuq

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from reopened to closed

This is fixed in os12, closing.

comment:13 Changed 8 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

We can move up and down in the dropdown for Browse in 12.1.0 os16/Browse-140.

comment:14 Changed 7 years ago by dnarvaez

  • Milestone 0.96 deleted

Milestone 0.96 deleted

Note: See TracTickets for help on using tickets.