Opened 8 years ago

Closed 7 years ago

#3166 closed defect (fixed)

'show' block with video clock crashes TA if object is not video

Reported by: garycmartin Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Testing in TA 116, the 'show' block with a video object attached draws a grey rectangle and then crashes TA if object was not actually video media. Would be great if there was some test done on it before trying to play the media. I accidently selected still png images by mistake the first few times I tried this block. Perhaps the icon representing the 'Sugar journal media object' could also be changed from the Journal icon to that of the Image viewer type picture frame?

Attachments (1)

ta_media_crash.log (2.3 KB) - added by garycmartin 8 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by walter

Hmm. My test must be failing. Will check it. Re the Journal icon, you can use it to open any Journal object. If it is not an image, it will try to use the preview image. So maybe I should add a block that is specifically for images???

comment:2 Changed 8 years ago by walter

Was there an except raised in the log file?

comment:3 follow-up: Changed 8 years ago by walter

I cannot seem to reproduce this error... a log file would help.

Changed 8 years ago by garycmartin

comment:4 in reply to: ↑ 3 Changed 8 years ago by garycmartin

Replying to walter:

I cannot seem to reproduce this error... a log file would help.

Here's the log. Steps to reproduce the cash:

1) drag on the 'show' brick
2) drag on the 'video object' and use it to replace the default 'text' object
3) click the 'video object' and chose an image (e.g. a Paint activity, a screen shot, or a downloaded png image)
4) click 'show' once to run the brick

You briefly see a grey box and then TA will crash.

comment:5 Changed 7 years ago by walter

I think I have fixed the problem with movies crashing in general.

http://git.sugarlabs.org/turtleart/mainline/commit/7d5b1dffa0e28c7e06c5f585311aaae18a8a646d

I cannot otherwise reproduce this bug. Please pull and test.

comment:6 Changed 7 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

When I try to reproduce this bug since fixing the general issues with movie playback, I cannot crash TA. When repeating the steps above, I get an image displayed. Please reopen this ticket if the problem persists.

Note: See TracTickets for help on using tickets.